diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch | 69 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | 40 |
2 files changed, 109 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch new file mode 100644 index 000000000..38504fef6 --- /dev/null +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch | |||
@@ -0,0 +1,69 @@ | |||
1 | Index: git/configure | ||
2 | =================================================================== | ||
3 | --- git.orig/configure 2012-11-19 21:07:51.917429465 -0800 | ||
4 | +++ git/configure 2012-11-19 21:13:19.337437278 -0800 | ||
5 | @@ -275,8 +275,11 @@ | ||
6 | assert "$SYSTEM" "$SYSTEM" "unsupported" | ||
7 | |||
8 | CORES=${CORES:-${DCORES}} | ||
9 | -printf "Detecting machine architecture..." | ||
10 | -PLATFORM=`uname -m 2> /dev/null` | ||
11 | +if test -z "$PLATFORM"; then | ||
12 | + printf "Detecting machine architecture..." | ||
13 | + PLATFORM=`uname -m 2> /dev/null` | ||
14 | +fi | ||
15 | + | ||
16 | case $PLATFORM in | ||
17 | "macppc"|"Power Macintosh"|"powerpc") | ||
18 | MM="${MM:-"CK_MD_RMO"}" | ||
19 | @@ -439,14 +442,18 @@ | ||
20 | GZIP_SUFFIX=".gz" | ||
21 | fi | ||
22 | |||
23 | -printf "Finding suitable compiler........" | ||
24 | -CC=`pathsearch "${CC:-cc}"` | ||
25 | -if test -z "$CC" -o ! -x "$CC"; then | ||
26 | - CC=`pathsearch "${CC:-gcc}"` | ||
27 | +if test -z "$CC"; then | ||
28 | + printf "Finding suitable compiler........" | ||
29 | + CC=`pathsearch "${CC:-cc}"` | ||
30 | + if test -z "$CC" -o ! -x "$CC"; then | ||
31 | + CC=`pathsearch "${CC:-gcc}"` | ||
32 | + fi | ||
33 | fi | ||
34 | assert "$CC" "not found" | ||
35 | |||
36 | -cat << EOF > .1.c | ||
37 | +if test -z "$COMPILER"; then | ||
38 | + | ||
39 | + cat << EOF > .1.c | ||
40 | #include <stdio.h> | ||
41 | int main(void) { | ||
42 | #if defined(__GNUC__) && (__GNUC__ >= 4) | ||
43 | @@ -460,16 +467,16 @@ | ||
44 | #endif | ||
45 | } | ||
46 | EOF | ||
47 | - | ||
48 | -$CC -o .1 .1.c | ||
49 | -COMPILER=`./.1` | ||
50 | -r=$? | ||
51 | -rm -f .1.c .1 | ||
52 | - | ||
53 | -if test "$r" -ne 0; then | ||
54 | - assert "" "update compiler" | ||
55 | -else | ||
56 | - echo "success [$CC]" | ||
57 | + $CC -o .1 .1.c | ||
58 | + COMPILER=`./.1` | ||
59 | + r=$? | ||
60 | + rm -f .1.c .1 | ||
61 | + | ||
62 | + if test "$r" -ne 0; then | ||
63 | + assert "" "update compiler" | ||
64 | + else | ||
65 | + echo "success [$CC]" | ||
66 | + fi | ||
67 | fi | ||
68 | |||
69 | if test "$COMPILER" = "suncc"; then | ||
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb new file mode 100644 index 000000000..b0ff5cf45 --- /dev/null +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \ | ||
2 | safe memory reclamation mechanisms and non-blocking data structures \ | ||
3 | designed to aid in the design and implementation of high performance \ | ||
4 | concurrent systems." | ||
5 | |||
6 | LICENSE = "BSD & Apache-2.0" | ||
7 | HOMEPAGE = "http://concurrencykit.org" | ||
8 | SECTION = "base" | ||
9 | |||
10 | SRCREV = "900d203aa9e41288545368ea40da0bee89f7907f" | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f12611e65e064515ce264249b2bdea98" | ||
12 | SRC_URI = "git://git.concurrencykit.org/ck.git;protocol=git \ | ||
13 | file://cross.patch \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*" | ||
19 | |||
20 | inherit autotools | ||
21 | |||
22 | PLAT_powerpc64 = "ppc64" | ||
23 | PLAT ?= "${HOST_ARCH}" | ||
24 | |||
25 | do_configure () { | ||
26 | export PLATFORM=${PLAT} | ||
27 | export COMPILER='gcc' | ||
28 | ${S}/configure \ | ||
29 | --prefix=${prefix} \ | ||
30 | --includedir=${includedir} \ | ||
31 | --libdir=${libdir} \ | ||
32 | } | ||
33 | |||
34 | do_compile () { | ||
35 | oe_runmake | ||
36 | } | ||
37 | |||
38 | do_install () { | ||
39 | oe_runmake 'DESTDIR=${D}' install | ||
40 | } | ||