diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb | 65 |
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch deleted file mode 100644 index 36e8bf1c9..000000000 --- a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | Fix hardfloat detection | ||
2 | |||
3 | gcc has a builtin define to denote hard abi when in use, e.g. when | ||
4 | using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore | ||
5 | we should check that to determine which calling convention is in use | ||
6 | and not __VFP_FP__ which merely indicates presence of VFP unit | ||
7 | |||
8 | The fix has been provided by Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | Upstream-Status: Forwarded | ||
11 | |||
12 | --- a/deps/v8/src/platform-linux.cc 2012-05-17 12:52:59.329519921 -0700 | ||
13 | +++ b/deps/v8/src/platform-linux.cc 2012-05-17 12:54:02.037521511 -0700 | ||
14 | @@ -212,7 +212,7 @@ | ||
15 | // calling this will return 1.0 and otherwise 0.0. | ||
16 | static void ArmUsingHardFloatHelper() { | ||
17 | asm("mov r0, #0"); | ||
18 | -#if defined(__VFP_FP__) && !defined(__SOFTFP__) | ||
19 | +#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__) | ||
20 | // Load 0x3ff00000 into r1 using instructions available in both ARM | ||
21 | // and Thumb mode. | ||
22 | asm("mov r1, #3"); | ||
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb deleted file mode 100644 index 3d034f2fc..000000000 --- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb +++ /dev/null | |||
@@ -1,65 +0,0 @@ | |||
1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" | ||
2 | HOMEPAGE = "http://nodejs.org" | ||
3 | LICENSE = "MIT & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=914812f2875eef849b5c509cc25dcb4f" | ||
5 | |||
6 | DEPENDS = "openssl" | ||
7 | |||
8 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \ | ||
9 | file://fix-hardfloat-detection.patch" | ||
10 | SRC_URI[md5sum] = "0da985a0bf820400af92363b9f453fe4" | ||
11 | SRC_URI[sha256sum] = "22265fd07e09c22f1d058156d548e7398c9740210f534e2f848eeab5b9772117" | ||
12 | |||
13 | S = "${WORKDIR}/node-v${PV}" | ||
14 | |||
15 | # v8 errors out if you have set CCACHE | ||
16 | CCACHE = "" | ||
17 | |||
18 | do_configure_virtclass-native () { | ||
19 | sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript | ||
20 | sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript | ||
21 | |||
22 | ./configure --prefix=${prefix} --without-snapshot | ||
23 | } | ||
24 | |||
25 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons | ||
26 | do_configure () { | ||
27 | echo '#!/bin/sh' > ${WORKDIR}/gcc | ||
28 | echo '${CC} $@' >> ${WORKDIR}/gcc | ||
29 | |||
30 | echo '#!/bin/sh' > ${WORKDIR}/g++ | ||
31 | echo '${CXX} $@'>> ${WORKDIR}/g++ | ||
32 | |||
33 | chmod +x ${WORKDIR}/gcc ${WORKDIR}/g++ | ||
34 | |||
35 | sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript | ||
36 | sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript | ||
37 | |||
38 | export PATH=${WORKDIR}:${PATH} | ||
39 | export CC=gcc | ||
40 | export CXX=g++ | ||
41 | |||
42 | ./configure --prefix=${prefix} --without-snapshot | ||
43 | } | ||
44 | |||
45 | do_compile_virtclass-native () { | ||
46 | make BUILDTYPE=Release | ||
47 | } | ||
48 | |||
49 | do_compile () { | ||
50 | export PATH=${WORKDIR}:${PATH} | ||
51 | export CC=gcc | ||
52 | export CXX=g++ | ||
53 | make BUILDTYPE=Release | ||
54 | } | ||
55 | |||
56 | do_install () { | ||
57 | export DESTDIR=${D} | ||
58 | oe_runmake install | ||
59 | } | ||
60 | |||
61 | RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient " | ||
62 | RDEPENDS_${PN}_virtclass-native = "curl-native python-native" | ||
63 | |||
64 | FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules" | ||
65 | BBCLASSEXTEND = "native" | ||