diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc | 14 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service | 13 |
3 files changed, 27 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc b/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc index d6f3a54c3..ef99f489c 100644 --- a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc +++ b/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc | |||
@@ -9,9 +9,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | |||
9 | #at least versions 2.15 and prior are moved to the archive folder on the server | 9 | #at least versions 2.15 and prior are moved to the archive folder on the server |
10 | SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getVar('PV',1).split('.')[1]) > 15]}dnsmasq-${PV}.tar.gz;name=dnsmasq-${PV} \ | 10 | SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getVar('PV',1).split('.')[1]) > 15]}dnsmasq-${PV}.tar.gz;name=dnsmasq-${PV} \ |
11 | file://init \ | 11 | file://init \ |
12 | file://dnsmasq.conf" | 12 | file://dnsmasq.conf \ |
13 | file://dnsmasq.service \ | ||
14 | " | ||
13 | 15 | ||
14 | inherit update-rc.d | 16 | inherit update-rc.d systemd |
15 | 17 | ||
16 | INITSCRIPT_NAME = "dnsmasq" | 18 | INITSCRIPT_NAME = "dnsmasq" |
17 | INITSCRIPT_PARAMS = "defaults" | 19 | INITSCRIPT_PARAMS = "defaults" |
@@ -24,6 +26,14 @@ do_install () { | |||
24 | install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d ${D}${sysconfdir}/dnsmasq.d | 26 | install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d ${D}${sysconfdir}/dnsmasq.d |
25 | install -m 644 ${WORKDIR}/dnsmasq.conf ${D}${sysconfdir}/ | 27 | install -m 644 ${WORKDIR}/dnsmasq.conf ${D}${sysconfdir}/ |
26 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dnsmasq | 28 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dnsmasq |
29 | |||
30 | install -d ${D}${systemd_unitdir}/system | ||
31 | install -m 0644 ${WORKDIR}/dnsmasq.service ${D}${systemd_unitdir}/system | ||
27 | } | 32 | } |
28 | 33 | ||
29 | CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf" | 34 | CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf" |
35 | |||
36 | RPROVIDES_${PN} += "${PN}-systemd" | ||
37 | RREPLACES_${PN} += "${PN}-systemd" | ||
38 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
39 | SYSTEMD_SERVICE_${PN} = "dnsmasq.service" | ||
diff --git a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb b/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb index 5f877047f..ae37db739 100644 --- a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb +++ b/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb | |||
@@ -1,4 +1,6 @@ | |||
1 | require dnsmasq.inc | 1 | require dnsmasq.inc |
2 | 2 | ||
3 | PR = "r3" | ||
4 | |||
3 | SRC_URI[dnsmasq-2.55.md5sum] = "b093d7c6bc7f97ae6fd35d048529232a" | 5 | SRC_URI[dnsmasq-2.55.md5sum] = "b093d7c6bc7f97ae6fd35d048529232a" |
4 | SRC_URI[dnsmasq-2.55.sha256sum] = "cf63ecf5977f00474cbda98376a9d8743500a82fd98e13f43d7037bce9f9f929" | 6 | SRC_URI[dnsmasq-2.55.sha256sum] = "cf63ecf5977f00474cbda98376a9d8743500a82fd98e13f43d7037bce9f9f929" |
diff --git a/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service b/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service new file mode 100644 index 000000000..549e15e2b --- /dev/null +++ b/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=DNS forwarder and DHCP server | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | PIDFile=/run/dnsmasq.pid | ||
8 | ExecStart=/usr/bin/dnsmasq -x /run/dnsmasq.pid | ||
9 | ExecReload=/bin/kill -HUP $(/bin/cat /run/dnsmasq.pid) | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
13 | |||