diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace/0001-Makefile-Add-LDFLAGS-in-export.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace/0002-utils-Add-limits-header-to-fix-build-error.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb (renamed from meta-oe/recipes-devtools/uftrace/uftrace_0.7.bb) | 8 |
3 files changed, 2 insertions, 68 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-Makefile-Add-LDFLAGS-in-export.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-Makefile-Add-LDFLAGS-in-export.patch deleted file mode 100644 index f665051e9..000000000 --- a/meta-oe/recipes-devtools/uftrace/uftrace/0001-Makefile-Add-LDFLAGS-in-export.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From ec794945475d5792f2ae85afe461e64266613640 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changhyeok Bae <changhyeok.bae@gmail.com> | ||
3 | Date: Thu, 13 Jul 2017 16:44:52 +0900 | ||
4 | Subject: [PATCH 1/2] Makefile: Add LDFLAGS in export | ||
5 | |||
6 | To use build with musl, need to argp library. | ||
7 | So need to add LDFLAGS from outside. | ||
8 | |||
9 | Upstream-Status: Accepted | ||
10 | |||
11 | Signed-off-by: <Changhyeok Bae changhyeok.bae@gmail.com> | ||
12 | --- | ||
13 | Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index 67be2da..0ca649a 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -48,7 +48,7 @@ endif | ||
21 | RM = rm -f | ||
22 | INSTALL = install | ||
23 | |||
24 | -export ARCH CC AR LD RM srcdir objdir | ||
25 | +export ARCH CC AR LD RM srcdir objdir LDFLAGS | ||
26 | |||
27 | COMMON_CFLAGS := -O2 -g -D_GNU_SOURCE $(CFLAGS) $(CPPFLAGS) | ||
28 | COMMON_CFLAGS += -iquote $(srcdir) -iquote $(objdir) -iquote $(srcdir)/arch/$(ARCH) | ||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0002-utils-Add-limits-header-to-fix-build-error.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0002-utils-Add-limits-header-to-fix-build-error.patch deleted file mode 100644 index 269001158..000000000 --- a/meta-oe/recipes-devtools/uftrace/uftrace/0002-utils-Add-limits-header-to-fix-build-error.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 3bda554766150705160fe2191d8761c7881e2433 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changhyeok Bae <changhyeok.bae@gmail.com> | ||
3 | Date: Thu, 13 Jul 2017 16:46:20 +0900 | ||
4 | Subject: [PATCH 2/2] utils: Add limits header to fix build error | ||
5 | |||
6 | [Error] | ||
7 | error: 'PATH_MAX' undeclared (first use in this function); did you mean | ||
8 | 'INT8_MAX'? | ||
9 | |||
10 | Upstream-Status: Accepted | ||
11 | |||
12 | Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> | ||
13 | --- | ||
14 | utils/utils.c | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/utils/utils.c b/utils/utils.c | ||
18 | index 03522c9..30f9e81 100644 | ||
19 | --- a/utils/utils.c | ||
20 | +++ b/utils/utils.c | ||
21 | @@ -6,6 +6,7 @@ | ||
22 | #include <errno.h> | ||
23 | #include <sys/uio.h> | ||
24 | #include <sys/stat.h> | ||
25 | +#include <limits.h> | ||
26 | |||
27 | #include "utils/utils.h" | ||
28 | |||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.7.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb index 821d0bbc2..82b179521 100644 --- a/meta-oe/recipes-devtools/uftrace/uftrace_0.7.bb +++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb | |||
@@ -10,12 +10,8 @@ DEPENDS_append_libc-musl = " argp-standalone" | |||
10 | 10 | ||
11 | inherit autotools | 11 | inherit autotools |
12 | 12 | ||
13 | SRCREV = "712ad01fdde57893936d7e254451eec67ab41ca6" | 13 | SRCREV = "5af9ff9fa89c340617e52c8ed05798b352a7145c" |
14 | SRC_URI = "\ | 14 | SRC_URI = "git://github.com/namhyung/${BPN}" |
15 | git://github.com/namhyung/${BPN} \ | ||
16 | file://0001-Makefile-Add-LDFLAGS-in-export.patch \ | ||
17 | file://0002-utils-Add-limits-header-to-fix-build-error.patch \ | ||
18 | " | ||
19 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
20 | 16 | ||
21 | LDFLAGS_append_libc-musl = " -largp" | 17 | LDFLAGS_append_libc-musl = " -largp" |