diff options
Diffstat (limited to 'meta-oe')
30 files changed, 40 insertions, 40 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb index 3c6954855..fdf54e3b1 100644 --- a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb +++ b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | |||
6 | 6 | ||
7 | inherit autotools | 7 | inherit autotools |
8 | 8 | ||
9 | # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from | 9 | # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from |
10 | # Launchpad until the next release is available from Github. | 10 | # Launchpad until the next release is available from Github. |
11 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz" | 11 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz" |
12 | 12 | ||
@@ -22,5 +22,5 @@ PACKAGECONFIG[mysql] = "--with-mysql \ | |||
22 | --without-mysql,mysql5" | 22 | --without-mysql,mysql5" |
23 | 23 | ||
24 | do_configure_prepend() { | 24 | do_configure_prepend() { |
25 | touch ${S}/NEWS ${S}/AUTHORS | 25 | touch ${S}/NEWS ${S}/AUTHORS |
26 | } | 26 | } |
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb index 21dd1deb6..a53fa69de 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb | |||
@@ -22,7 +22,7 @@ MACHINE_EXTRA_RRECOMMENDS ?= "" | |||
22 | TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server" | 22 | TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server" |
23 | 23 | ||
24 | # | 24 | # |
25 | # The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom | 25 | # The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom |
26 | # when writing image recipes. | 26 | # when writing image recipes. |
27 | # It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a | 27 | # It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a |
28 | # distro feature. | 28 | # distro feature. |
@@ -38,7 +38,7 @@ RDEPENDS_${PN} = "\ | |||
38 | # The following section is split in 3: | 38 | # The following section is split in 3: |
39 | # 1) Machine features: kernel modules and userspace helpers for those | 39 | # 1) Machine features: kernel modules and userspace helpers for those |
40 | # 2) Distro features: packages associated with those | 40 | # 2) Distro features: packages associated with those |
41 | # 3) Nice to have: packages that are nice to have, but aren't strictly needed | 41 | # 3) Nice to have: packages that are nice to have, but aren't strictly needed |
42 | # | 42 | # |
43 | RRECOMMENDS_${PN} = "\ | 43 | RRECOMMENDS_${PN} = "\ |
44 | ${MACHINE_EXTRA_RRECOMMENDS} \ | 44 | ${MACHINE_EXTRA_RRECOMMENDS} \ |
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb index 87e524dd7..6940d2da4 100644 --- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb +++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb | |||
@@ -101,7 +101,7 @@ do_install () { | |||
101 | 101 | ||
102 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ | 102 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ |
103 | install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ | 103 | install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ |
104 | 104 | ||
105 | install -d ${D}${systemd_unitdir}/system | 105 | install -d ${D}${systemd_unitdir}/system |
106 | install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system | 106 | install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system |
107 | } | 107 | } |
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb b/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb index 4d677efb1..e7a406fc5 100644 --- a/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb +++ b/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb | |||
@@ -20,7 +20,7 @@ RDEPENDS_${PN} = "ncurses" | |||
20 | EXTRA_OEMAKE = "-e MAKEFLAGS=" | 20 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
21 | 21 | ||
22 | do_compile() { | 22 | do_compile() { |
23 | oe_runmake -C src all | 23 | oe_runmake -C src all |
24 | } | 24 | } |
25 | 25 | ||
26 | do_install_append() { | 26 | do_install_append() { |
@@ -33,7 +33,7 @@ do_install() { | |||
33 | TARGET=${D}${bindir} \ | 33 | TARGET=${D}${bindir} \ |
34 | WORKDIR=${D}${localstatedir}/local/iptraf \ | 34 | WORKDIR=${D}${localstatedir}/local/iptraf \ |
35 | LOGDIR=${D}${localstatedir}/log/iptraf \ | 35 | LOGDIR=${D}${localstatedir}/log/iptraf \ |
36 | LOCKDIR=${D}${localstatedir}/run/iptraf | 36 | LOCKDIR=${D}${localstatedir}/run/iptraf |
37 | } | 37 | } |
38 | 38 | ||
39 | FILES_${PN} += "${bindir} ${localstatedir} /run" | 39 | FILES_${PN} += "${bindir} ${localstatedir} /run" |
diff --git a/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb b/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb index ab15a7e7f..3eadbe45f 100644 --- a/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb +++ b/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb | |||
@@ -1,12 +1,12 @@ | |||
1 | SUMMARY = "Templatized C++ Command Line Parser" | 1 | SUMMARY = "Templatized C++ Command Line Parser" |
2 | HOMEPAGE = "http://tclap.sourceforge.net/" | 2 | HOMEPAGE = "http://tclap.sourceforge.net/" |
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c8ab0ff134bcc584d0e6b5b9f8732453" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c8ab0ff134bcc584d0e6b5b9f8732453" |
5 | 5 | ||
6 | SRCREV = "3627d9402e529770df9b0edf2aa8c0e0d6c6bb41" | 6 | SRCREV = "3627d9402e529770df9b0edf2aa8c0e0d6c6bb41" |
7 | SRC_URI = "git://git.code.sf.net/p/tclap/code \ | 7 | SRC_URI = "git://git.code.sf.net/p/tclap/code \ |
8 | file://Makefile.am-disable-docs.patch \ | 8 | file://Makefile.am-disable-docs.patch \ |
9 | " | 9 | " |
10 | 10 | ||
11 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
12 | inherit autotools | 12 | inherit autotools |
diff --git a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb index f5d056e00..b848b0693 100644 --- a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb +++ b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb | |||
@@ -29,10 +29,10 @@ PACKAGES = "libxerces-c \ | |||
29 | xerces-c-samples \ | 29 | xerces-c-samples \ |
30 | xerces-c-samples-dbg \ | 30 | xerces-c-samples-dbg \ |
31 | libxerces-c-staticdev \ | 31 | libxerces-c-staticdev \ |
32 | " | 32 | " |
33 | 33 | ||
34 | FILES_libxerces-c = "${libdir}/libxerces-c-3.1.so" | 34 | FILES_libxerces-c = "${libdir}/libxerces-c-3.1.so" |
35 | FILES_libxerces-c-dbg = "${libdir}/.debug \ | 35 | FILES_libxerces-c-dbg = "${libdir}/.debug \ |
36 | ${prefix}/src/debug \ | 36 | ${prefix}/src/debug \ |
37 | " | 37 | " |
38 | FILES_libxerces-c-dev = "${libdir}/lib*.la \ | 38 | FILES_libxerces-c-dev = "${libdir}/lib*.la \ |
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb index 524f2a543..d477f4bb0 100644 --- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb +++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | |||
@@ -10,7 +10,7 @@ SRC_URI = " \ | |||
10 | file://0003-Add-AArch64-support.patch;patchdir=../../ \ | 10 | file://0003-Add-AArch64-support.patch;patchdir=../../ \ |
11 | file://0004-mozbug746112-no-decommit-on-large-pages.patch;patchdir=../../ \ | 11 | file://0004-mozbug746112-no-decommit-on-large-pages.patch;patchdir=../../ \ |
12 | file://0005-aarch64-64k-page.patch;patchdir=../../ \ | 12 | file://0005-aarch64-64k-page.patch;patchdir=../../ \ |
13 | file://0001-regenerate-configure.patch;patchdir=../../ \ | 13 | file://0001-regenerate-configure.patch;patchdir=../../ \ |
14 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ | 14 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ |
15 | file://fix_milestone_compile_issue.patch \ | 15 | file://fix_milestone_compile_issue.patch \ |
16 | file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \ | 16 | file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \ |
@@ -46,7 +46,7 @@ PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${ST | |||
46 | 46 | ||
47 | # mozjs requires autoreconf 2.13 | 47 | # mozjs requires autoreconf 2.13 |
48 | do_configure() { | 48 | do_configure() { |
49 | ( cd ${S} | 49 | ( cd ${S} |
50 | gnu-configize --force | 50 | gnu-configize --force |
51 | mv config.guess config.sub build/autoconf ) | 51 | mv config.guess config.sub build/autoconf ) |
52 | ${S}/configure ${EXTRA_OECONF} | 52 | ${S}/configure ${EXTRA_OECONF} |
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb index 41626d156..84e465d85 100644 --- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | |||
@@ -20,7 +20,7 @@ SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ | |||
20 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ | 20 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ |
21 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ | 21 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ |
22 | file://sfcb.service" | 22 | file://sfcb.service" |
23 | 23 | ||
24 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" | 24 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" |
25 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" | 25 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
26 | 26 | ||
@@ -58,7 +58,7 @@ do_install() { | |||
58 | install -d ${D}${sysconfdir}/init.d | 58 | install -d ${D}${sysconfdir}/init.d |
59 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb | 59 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb |
60 | sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb | 60 | sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb |
61 | 61 | ||
62 | rm -rf ${D}${libdir}/sfcb/*.la | 62 | rm -rf ${D}${libdir}/sfcb/*.la |
63 | } | 63 | } |
64 | 64 | ||
diff --git a/meta-oe/recipes-extended/sysdig/sysdig_git.bb b/meta-oe/recipes-extended/sysdig/sysdig_git.bb index 717fab93a..bc6fec0f1 100644 --- a/meta-oe/recipes-extended/sysdig/sysdig_git.bb +++ b/meta-oe/recipes-extended/sysdig/sysdig_git.bb | |||
@@ -30,6 +30,6 @@ EXTRA_OECMAKE = ' -DUSE_BUNDLED_LUAJIT="OFF" \ | |||
30 | 30 | ||
31 | FILES_${PN} += " \ | 31 | FILES_${PN} += " \ |
32 | ${DIR_ETC}/* \ | 32 | ${DIR_ETC}/* \ |
33 | ${datadir}/zsh/* \ | 33 | ${datadir}/zsh/* \ |
34 | ${prefix}/src/* \ | 34 | ${prefix}/src/* \ |
35 | " | 35 | " |
diff --git a/meta-oe/recipes-extended/tiptop/tiptop_2.3.bb b/meta-oe/recipes-extended/tiptop/tiptop_2.3.bb index 5a981166b..d729de9bb 100644 --- a/meta-oe/recipes-extended/tiptop/tiptop_2.3.bb +++ b/meta-oe/recipes-extended/tiptop/tiptop_2.3.bb | |||
@@ -15,7 +15,7 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc).*-linux" | |||
15 | do_configure_prepend () { | 15 | do_configure_prepend () { |
16 | # Two bugs in configure.ac when cross-compiling. | 16 | # Two bugs in configure.ac when cross-compiling. |
17 | # 1. The path of libxml2. Specify it in EXTRA_OECONF. | 17 | # 1. The path of libxml2. Specify it in EXTRA_OECONF. |
18 | # 2. hw's value on other platforms. Replace it if the target is | 18 | # 2. hw's value on other platforms. Replace it if the target is |
19 | # not i*86/x86_64. | 19 | # not i*86/x86_64. |
20 | if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then | 20 | if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then |
21 | sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac | 21 | sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac |
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb index 78c65648f..74c066f58 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "git://git.openmoko.org/git/xf86-video-glamo.git;branch=master \ | |||
13 | file://0001-glamo-kms-driver-drop-unused-xf86_config.patch \ | 13 | file://0001-glamo-kms-driver-drop-unused-xf86_config.patch \ |
14 | file://0001-fix-build-with-KMS-disabled.patch \ | 14 | file://0001-fix-build-with-KMS-disabled.patch \ |
15 | file://0003-glamo-driver-adapt-to-xserver-0.13-video-API.patch \ | 15 | file://0003-glamo-driver-adapt-to-xserver-0.13-video-API.patch \ |
16 | file://0001-glamo-driver-remove-references-to-mibstore.patch \ | 16 | file://0001-glamo-driver-remove-references-to-mibstore.patch \ |
17 | file://0004-glamo.h-use-const-for-jbt6k74_state_path.patch \ | 17 | file://0004-glamo.h-use-const-for-jbt6k74_state_path.patch \ |
18 | " | 18 | " |
19 | 19 | ||
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb index ce13b71ef..06fe1a84a 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb | |||
@@ -14,7 +14,7 @@ DEPENDS = "zlib readline" | |||
14 | 14 | ||
15 | SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ | 15 | SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ |
16 | http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz;name=gdb;subdir=${BP} \ | 16 | http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz;name=gdb;subdir=${BP} \ |
17 | file://7001force_define_architecture.patch \ | 17 | file://7001force_define_architecture.patch \ |
18 | file://7003cross_ranlib.patch \ | 18 | file://7003cross_ranlib.patch \ |
19 | file://0001-cross_add_configure_option.patch \ | 19 | file://0001-cross_add_configure_option.patch \ |
20 | file://sim-ppc-drop-LIBS-from-psim-dependency.patch \ | 20 | file://sim-ppc-drop-LIBS-from-psim-dependency.patch \ |
diff --git a/meta-oe/recipes-multimedia/libmad/libmad_0.15.1b.bb b/meta-oe/recipes-multimedia/libmad/libmad_0.15.1b.bb index 20983a775..3a647bf67 100644 --- a/meta-oe/recipes-multimedia/libmad/libmad_0.15.1b.bb +++ b/meta-oe/recipes-multimedia/libmad/libmad_0.15.1b.bb | |||
@@ -19,7 +19,7 @@ SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz \ | |||
19 | " | 19 | " |
20 | 20 | ||
21 | SRC_URI[md5sum] = "1be543bc30c56fb6bea1d7bf6a64e66c" | 21 | SRC_URI[md5sum] = "1be543bc30c56fb6bea1d7bf6a64e66c" |
22 | SRC_URI[sha256sum] = "bbfac3ed6bfbc2823d3775ebb931087371e142bb0e9bb1bee51a76a6e0078690" | 22 | SRC_URI[sha256sum] = "bbfac3ed6bfbc2823d3775ebb931087371e142bb0e9bb1bee51a76a6e0078690" |
23 | 23 | ||
24 | S = "${WORKDIR}/libmad-${PV}" | 24 | S = "${WORKDIR}/libmad-${PV}" |
25 | 25 | ||
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb index 145497a46..330dfd3e7 100644 --- a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb +++ b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb | |||
@@ -139,7 +139,7 @@ do_configure() { | |||
139 | sed -i 's|extra_cflags="-I. $extra_cflags"|extra_cflags="-I. -I${STAGING_INCDIR}/directfb $extra_cflags"|g' ${S}/configure | 139 | sed -i 's|extra_cflags="-I. $extra_cflags"|extra_cflags="-I. -I${STAGING_INCDIR}/directfb $extra_cflags"|g' ${S}/configure |
140 | export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)" | 140 | export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)" |
141 | ./configure ${EXTRA_OECONF} | 141 | ./configure ${EXTRA_OECONF} |
142 | 142 | ||
143 | } | 143 | } |
144 | 144 | ||
145 | do_compile () { | 145 | do_compile () { |
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bb b/meta-oe/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bb index d023c5de7..d2058ba57 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bb | |||
@@ -4,4 +4,4 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD;md5=377548 | |||
4 | 4 | ||
5 | # empty by default | 5 | # empty by default |
6 | # BSP layers can add stuff like meta-openmoko example: | 6 | # BSP layers can add stuff like meta-openmoko example: |
7 | # | 7 | # |
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb index 35c891e7a..3ef179295 100644 --- a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb +++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb | |||
@@ -22,7 +22,7 @@ do_configure() { | |||
22 | cp -R --no-dereference --preserve=mode,links -v ${S}/autoconf/configure.in ${S} | 22 | cp -R --no-dereference --preserve=mode,links -v ${S}/autoconf/configure.in ${S} |
23 | 23 | ||
24 | if ! [ -d ${S}/platforms/${DISTRO} ] ; then | 24 | if ! [ -d ${S}/platforms/${DISTRO} ] ; then |
25 | cp -R --no-dereference --preserve=mode,links -v ${S}/platforms/unknown ${S}/platforms/${DISTRO} | 25 | cp -R --no-dereference --preserve=mode,links -v ${S}/platforms/unknown ${S}/platforms/${DISTRO} |
26 | fi | 26 | fi |
27 | 27 | ||
28 | gnu-configize --force | 28 | gnu-configize --force |
diff --git a/meta-oe/recipes-support/emacs/emacs.inc b/meta-oe/recipes-support/emacs/emacs.inc index ffb5c50c7..012895e85 100644 --- a/meta-oe/recipes-support/emacs/emacs.inc +++ b/meta-oe/recipes-support/emacs/emacs.inc | |||
@@ -14,7 +14,7 @@ X11DEPENDS = " \ | |||
14 | libx11 libxau libxcomposite libxcursor libxdamage libxdmcp libxext libxfixes \ | 14 | libx11 libxau libxcomposite libxcursor libxdamage libxdmcp libxext libxfixes \ |
15 | libxft libxpm libxrandr libxrender \ | 15 | libxft libxpm libxrandr libxrender \ |
16 | gdk-pixbuf glib-2.0 gtk+ pango libxcb harfbuzz icu \ | 16 | gdk-pixbuf glib-2.0 gtk+ pango libxcb harfbuzz icu \ |
17 | " | 17 | " |
18 | 18 | ||
19 | EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} " | 19 | EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} " |
20 | 20 | ||
@@ -55,7 +55,7 @@ do_compile_prepend() { | |||
55 | if [ -e $treedir ];then | 55 | if [ -e $treedir ];then |
56 | rm -rf $treedir | 56 | rm -rf $treedir |
57 | fi | 57 | fi |
58 | 58 | ||
59 | mkdir -p $treedir/${base_libdir} | 59 | mkdir -p $treedir/${base_libdir} |
60 | 60 | ||
61 | if [ -f ${TOOLCHAIN_PATH}/${TARGET_SYS}/${base_libdir}/libgcc_s.so ]; then | 61 | if [ -f ${TOOLCHAIN_PATH}/${TARGET_SYS}/${base_libdir}/libgcc_s.so ]; then |
diff --git a/meta-oe/recipes-support/fftw/benchfft_3.1.bb b/meta-oe/recipes-support/fftw/benchfft_3.1.bb index d859386be..3e06a5a4b 100644 --- a/meta-oe/recipes-support/fftw/benchfft_3.1.bb +++ b/meta-oe/recipes-support/fftw/benchfft_3.1.bb | |||
@@ -2,7 +2,7 @@ SUMMARY = "FFTW benchmarks" | |||
2 | SECTION = "libs" | 2 | SECTION = "libs" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | 4 | ||
5 | # single precision fftw is called fftwf | 5 | # single precision fftw is called fftwf |
6 | DEPENDS = "virtual/fftw" | 6 | DEPENDS = "virtual/fftw" |
7 | 7 | ||
8 | SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz" | 8 | SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz" |
diff --git a/meta-oe/recipes-support/fftw/fftw.inc b/meta-oe/recipes-support/fftw/fftw.inc index 1522ea0bb..a0adf59be 100644 --- a/meta-oe/recipes-support/fftw/fftw.inc +++ b/meta-oe/recipes-support/fftw/fftw.inc | |||
@@ -16,7 +16,7 @@ inherit autotools pkgconfig | |||
16 | EXTRA_OECONF = "--disable-fortran --enable-shared --enable-threads" | 16 | EXTRA_OECONF = "--disable-fortran --enable-shared --enable-threads" |
17 | 17 | ||
18 | do_configure_prepend() { | 18 | do_configure_prepend() { |
19 | echo 'AM_PROG_AS' >> ${S}/configure.ac | 19 | echo 'AM_PROG_AS' >> ${S}/configure.ac |
20 | } | 20 | } |
21 | 21 | ||
22 | PACKAGES =+ "lib${BPN}" | 22 | PACKAGES =+ "lib${BPN}" |
diff --git a/meta-oe/recipes-support/ipmiutil/ipmiutil_2.9.6.bb b/meta-oe/recipes-support/ipmiutil/ipmiutil_2.9.6.bb index a4273fbd5..9e74df5a0 100644 --- a/meta-oe/recipes-support/ipmiutil/ipmiutil_2.9.6.bb +++ b/meta-oe/recipes-support/ipmiutil/ipmiutil_2.9.6.bb | |||
@@ -31,7 +31,7 @@ PACKAGECONFIG[systemd] = "--enable-systemd=${datadir}/${BPN}, --enable-systemd=n | |||
31 | PACKAGECONFIG[sha256] = "--enable-sha256, --enable-sha256=no, openssl-native, openssl" | 31 | PACKAGECONFIG[sha256] = "--enable-sha256, --enable-sha256=no, openssl-native, openssl" |
32 | PACKAGECONFIG[lanplus] = "--enable-lanplus, --enable-lanplus=no, openssl-native, openssl" | 32 | PACKAGECONFIG[lanplus] = "--enable-lanplus, --enable-lanplus=no, openssl-native, openssl" |
33 | PACKAGECONFIG[landesk] = "--enable-landesk, --enable-landesk=no" | 33 | PACKAGECONFIG[landesk] = "--enable-landesk, --enable-landesk=no" |
34 | PACKAGECONFIG[sensors] = "--enable-libsensors, --enable-libsensors=no" | 34 | PACKAGECONFIG[sensors] = "--enable-libsensors, --enable-libsensors=no" |
35 | 35 | ||
36 | #build with some GPL code | 36 | #build with some GPL code |
37 | PACKAGECONFIG[gpl] = "--enable-gpl, --enable-gpl=no" | 37 | PACKAGECONFIG[gpl] = "--enable-gpl, --enable-gpl=no" |
diff --git a/meta-oe/recipes-support/lcov/lcov_1.11.bb b/meta-oe/recipes-support/lcov/lcov_1.11.bb index 5f3b88934..114bd84cd 100644 --- a/meta-oe/recipes-support/lcov/lcov_1.11.bb +++ b/meta-oe/recipes-support/lcov/lcov_1.11.bb | |||
@@ -4,7 +4,7 @@ DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \ | |||
4 | tool gcov. It collects gcov data for multiple source files and creates \ | 4 | tool gcov. It collects gcov data for multiple source files and creates \ |
5 | HTML pages containing the source code annotated with coverage information. \ | 5 | HTML pages containing the source code annotated with coverage information. \ |
6 | It also adds overview pages for easy navigation within the file structure. \ | 6 | It also adds overview pages for easy navigation within the file structure. \ |
7 | LCOV supports statement, function and branch coverage measurement." | 7 | LCOV supports statement, function and branch coverage measurement." |
8 | LICENSE = "GPL-2.0" | 8 | LICENSE = "GPL-2.0" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
10 | 10 | ||
diff --git a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb index e09a5393d..4460be207 100644 --- a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb +++ b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | # (c) Copyright 2012 Hewlett-Packard Development Company, L.P. | 1 | # (c) Copyright 2012 Hewlett-Packard Development Company, L.P. |
2 | 2 | ||
3 | SUMMARY = "a simple, small, minimal, C++ XML parser" | 3 | SUMMARY = "a simple, small, minimal, C++ XML parser" |
4 | HOMEPAGE = "http://www.sourceforge.net/projects/tinyxml" | 4 | HOMEPAGE = "http://www.sourceforge.net/projects/tinyxml" |
diff --git a/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb b/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb index 3638019c4..b0091d657 100644 --- a/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb +++ b/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb | |||
@@ -48,7 +48,7 @@ PACKAGES =+ "${PN}-fancontrol" | |||
48 | PACKAGES =+ "${PN}-cgi" | 48 | PACKAGES =+ "${PN}-cgi" |
49 | RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi" | 49 | RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi" |
50 | RDEPENDS_${PN}-cgi = "${PN}-sensord rrdtool" | 50 | RDEPENDS_${PN}-cgi = "${PN}-sensord rrdtool" |
51 | FILES_${PN}-cgi = "/www/*" | 51 | FILES_${PN}-cgi = "/www/*" |
52 | 52 | ||
53 | # libsensors configuration file | 53 | # libsensors configuration file |
54 | FILES_${PN}-libsensors = "${sysconfdir}/sensors.d/sensors.conf" | 54 | FILES_${PN}-libsensors = "${sysconfdir}/sensors.d/sensors.conf" |
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb index ecaae4c08..b8e3a2d20 100644 --- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb | |||
@@ -35,7 +35,7 @@ do_install() { | |||
35 | done | 35 | done |
36 | } | 36 | } |
37 | 37 | ||
38 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" | 38 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" |
39 | FILES_${PN} += "${bindir} ${datadir}/opencv" | 39 | FILES_${PN} += "${bindir} ${datadir}/opencv" |
40 | 40 | ||
41 | PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv" | 41 | PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv" |
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 83e7de8c0..ced066f56 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -69,7 +69,7 @@ python populate_packages_prepend () { | |||
69 | metapkg = pn + '-dev' | 69 | metapkg = pn + '-dev' |
70 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") | 70 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") |
71 | blacklist = [ metapkg ] | 71 | blacklist = [ metapkg ] |
72 | metapkg_rdepends = [ ] | 72 | metapkg_rdepends = [ ] |
73 | packages = d.getVar('PACKAGES', 1).split() | 73 | packages = d.getVar('PACKAGES', 1).split() |
74 | for pkg in packages[1:]: | 74 | for pkg in packages[1:]: |
75 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): | 75 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): |
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.43.bb b/meta-oe/recipes-support/openldap/openldap_2.4.43.bb index 861836562..284db657c 100644 --- a/meta-oe/recipes-support/openldap/openldap_2.4.43.bb +++ b/meta-oe/recipes-support/openldap/openldap_2.4.43.bb | |||
@@ -71,7 +71,7 @@ EXTRA_OECONF += "--enable-crypt" | |||
71 | # SLAPD BACKEND | 71 | # SLAPD BACKEND |
72 | # | 72 | # |
73 | # The backend must be set by the configuration. This controls the | 73 | # The backend must be set by the configuration. This controls the |
74 | # required database. | 74 | # required database. |
75 | # | 75 | # |
76 | # Backends="bdb dnssrv hdb ldap mdb meta monitor ndb null passwd perl relay shell sock sql" | 76 | # Backends="bdb dnssrv hdb ldap mdb meta monitor ndb null passwd perl relay shell sock sql" |
77 | # | 77 | # |
diff --git a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb index 93cbdd7e3..f5896e6e1 100644 --- a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb +++ b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb | |||
@@ -61,7 +61,7 @@ do_install() { | |||
61 | install -d ${D}/etc/openwbem/openwbem.conf.d | 61 | install -d ${D}/etc/openwbem/openwbem.conf.d |
62 | install -d ${D}/var/adm/fillup-templates | 62 | install -d ${D}/var/adm/fillup-templates |
63 | install -m 644 etc/sysconfig/daemons/owcimomd ${D}/var/adm/fillup-templates/sysconfig.owcimomd | 63 | install -m 644 etc/sysconfig/daemons/owcimomd ${D}/var/adm/fillup-templates/sysconfig.owcimomd |
64 | 64 | ||
65 | # fix up hardcoded paths | 65 | # fix up hardcoded paths |
66 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service | 66 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service |
67 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 67 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
diff --git a/meta-oe/recipes-support/pidgin/pidgin_2.11.0.bb b/meta-oe/recipes-support/pidgin/pidgin_2.11.0.bb index d8b64b7c0..e9971467f 100644 --- a/meta-oe/recipes-support/pidgin/pidgin_2.11.0.bb +++ b/meta-oe/recipes-support/pidgin/pidgin_2.11.0.bb | |||
@@ -71,8 +71,8 @@ FILES_libpurple-dev = "${libdir}/libpurple*.la \ | |||
71 | ${datadir}/aclocal" | 71 | ${datadir}/aclocal" |
72 | FILES_libpurple-dbg += "${libdir}/.debug/libpurple* \ | 72 | FILES_libpurple-dbg += "${libdir}/.debug/libpurple* \ |
73 | ${libdir}/purple-2/.debug" | 73 | ${libdir}/purple-2/.debug" |
74 | FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so" | 74 | FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so" |
75 | FILES_libgnt-dev = "${libdir}/gnt/*.la" | 75 | FILES_libgnt-dev = "${libdir}/gnt/*.la" |
76 | FILES_libgnt-dbg = "${libdir}/gnt/.debug" | 76 | FILES_libgnt-dbg = "${libdir}/gnt/.debug" |
77 | FILES_finch = "${bindir}/finch" | 77 | FILES_finch = "${bindir}/finch" |
78 | FILES_finch-dev = "${libdir}/finch/*.la" | 78 | FILES_finch-dev = "${libdir}/finch/*.la" |
diff --git a/meta-oe/recipes-support/spitools/spitools_git.bb b/meta-oe/recipes-support/spitools/spitools_git.bb index a308e42c6..f8081256a 100644 --- a/meta-oe/recipes-support/spitools/spitools_git.bb +++ b/meta-oe/recipes-support/spitools/spitools_git.bb | |||
@@ -9,6 +9,6 @@ S = "${WORKDIR}/git" | |||
9 | SRC_URI = "git://github.com/cpb-/spi-tools.git;protocol=git" | 9 | SRC_URI = "git://github.com/cpb-/spi-tools.git;protocol=git" |
10 | 10 | ||
11 | SRCREV = "03405ab45884e4264dfa0371c032b2baaeeaaa98" | 11 | SRCREV = "03405ab45884e4264dfa0371c032b2baaeeaaa98" |
12 | 12 | ||
13 | inherit autotools | 13 | inherit autotools |
14 | 14 | ||
diff --git a/meta-oe/recipes-support/upower/upower_0.99.4.bb b/meta-oe/recipes-support/upower/upower_0.99.4.bb index 861f17ccf..770f33360 100644 --- a/meta-oe/recipes-support/upower/upower_0.99.4.bb +++ b/meta-oe/recipes-support/upower/upower_0.99.4.bb | |||
@@ -18,7 +18,7 @@ EXTRA_OECONF = " --with-backend=linux" | |||
18 | do_configure_prepend() { | 18 | do_configure_prepend() { |
19 | sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am | 19 | sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am |
20 | sed -i -e 's: doc : :g' ${S}/Makefile.am | 20 | sed -i -e 's: doc : :g' ${S}/Makefile.am |
21 | } | 21 | } |
22 | 22 | ||
23 | RDEPENDS_${PN} += "dbus" | 23 | RDEPENDS_${PN} += "dbus" |
24 | RRECOMMENDS_${PN} += "pm-utils" | 24 | RRECOMMENDS_${PN} += "pm-utils" |