diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch | 12 | ||||
-rw-r--r-- | meta-oe/recipes-support/fuse/fuse_2.8.6.bb | 36 |
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch b/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch new file mode 100644 index 000000000..c673a4c63 --- /dev/null +++ b/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: fuse-2.8.6/util/fusermount.c | ||
2 | =================================================================== | ||
3 | --- fuse-2.8.6.orig/util/fusermount.c 2011-09-13 00:23:14.000000000 -0700 | ||
4 | +++ fuse-2.8.6/util/fusermount.c 2011-09-25 00:23:53.051019038 -0700 | ||
5 | @@ -7,6 +7,7 @@ | ||
6 | */ | ||
7 | /* This program does the mounting and unmounting of FUSE filesystems */ | ||
8 | |||
9 | +#define _GNU_SOURCE | ||
10 | #include <config.h> | ||
11 | |||
12 | #include "mount_util.h" | ||
diff --git a/meta-oe/recipes-support/fuse/fuse_2.8.6.bb b/meta-oe/recipes-support/fuse/fuse_2.8.6.bb new file mode 100644 index 000000000..ec81a9833 --- /dev/null +++ b/meta-oe/recipes-support/fuse/fuse_2.8.6.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program" | ||
2 | HOMEPAGE = "http://fuse.sf.net" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "GPLv2&LGPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
6 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | ||
7 | |||
8 | PR = "r0" | ||
9 | |||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \ | ||
11 | file://define_GNU_SOURCE.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "eaa32c8cef56a981656a786f258a002a" | ||
15 | SRC_URI[sha256sum] = "1ec1913e38f09b2a9ec1579e1800805b5e2c747d1dce515e316dbb665ca139d6" | ||
16 | |||
17 | inherit autotools pkgconfig | ||
18 | |||
19 | EXTRA_OECONF = "--disable-kernel-module" | ||
20 | |||
21 | PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg" | ||
22 | |||
23 | RRECOMMENDS_${PN} = "kernel-module-fuse"" | ||
24 | |||
25 | FILES_${PN} += "${libdir}/libfuse.so.*" | ||
26 | FILES_${PN}-dev += "${libdir}/libfuse*.la" | ||
27 | |||
28 | FILES_libulockmgr = "${libdir}/libulockmgr.so.*" | ||
29 | FILES_libulockmgr-dev += "${libdir}/libulock*.la" | ||
30 | FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*" | ||
31 | |||
32 | # Forbid auto-renaming to libfuse-utils | ||
33 | FILES_fuse-utils = "${bindir} ${base_sbindir}" | ||
34 | FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug" | ||
35 | DEBIAN_NOAUTONAME_fuse-utils = "1" | ||
36 | DEBIAN_NOAUTONAME_fuse-utils-dbg = "1" | ||