diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb/cross-compile.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb/tbb.pc | 11 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb_4.1.bb | 31 |
3 files changed, 67 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb/cross-compile.patch b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch new file mode 100644 index 000000000..b970a374e --- /dev/null +++ b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Author: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> | ||
2 | |||
3 | Upstream-Status: unsuitable | ||
4 | --- | ||
5 | build/linux.gcc.inc | 5 +++-- | ||
6 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
7 | |||
8 | --- tbb41_20121003oss.orig/build/linux.gcc.inc | ||
9 | +++ tbb41_20121003oss/build/linux.gcc.inc | ||
10 | @@ -40,12 +40,13 @@ DYLIB_KEY = -shared | ||
11 | EXPORT_KEY = -Wl,--version-script, | ||
12 | LIBDL = -ldl | ||
13 | |||
14 | TBB_NOSTRICT = 1 | ||
15 | |||
16 | -CPLUS = g++ | ||
17 | -CONLY = gcc | ||
18 | +CPLUS = $(CXX) | ||
19 | +CONLY = $(CC) | ||
20 | +CPLUS_FLAGS = $(CXXFLAGS) | ||
21 | LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY) | ||
22 | LIBS += -lpthread -lrt | ||
23 | LINK_FLAGS = -Wl,-rpath-link=. | ||
24 | C_FLAGS = $(CPLUS_FLAGS) | ||
25 | # gcc 4.4 and higher support -std=c++0x | ||
diff --git a/meta-oe/recipes-support/tbb/tbb/tbb.pc b/meta-oe/recipes-support/tbb/tbb/tbb.pc new file mode 100644 index 000000000..644b64fbf --- /dev/null +++ b/meta-oe/recipes-support/tbb/tbb/tbb.pc | |||
@@ -0,0 +1,11 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=${exec_prefix}/lib | ||
4 | includedir=${prefix}/include | ||
5 | |||
6 | Name: Threading Building Blocks | ||
7 | Description: Intel's parallelism library for C++ | ||
8 | URL: http://www.threadingbuildingblocks.org/ | ||
9 | Version: 3.0+r018 | ||
10 | Libs: -L${libdir} -ltbb | ||
11 | Cflags: -I${includedir} | ||
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb_4.1.bb new file mode 100644 index 000000000..2337bddaa --- /dev/null +++ b/meta-oe/recipes-support/tbb/tbb_4.1.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ | ||
2 | TBB is a library that helps you leverage multi-core processor \ | ||
3 | performance without having to be a threading expert. It represents a \ | ||
4 | higher-level, task-based parallelism that abstracts platform details \ | ||
5 | and threading mechanism for performance and scalability." | ||
6 | HOMEPAGE = "http://threadingbuildingblocks.org/" | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=2c7f2caf277a3933e3acdf7f89d54cc1" | ||
9 | PRDATE = "20130116" | ||
10 | PR = "r${PRDATE}" | ||
11 | |||
12 | SRC_URI = "http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_${PRDATE}oss_src.tgz \ | ||
13 | file://cross-compile.patch \ | ||
14 | file://tbb.pc" | ||
15 | |||
16 | S = "${WORKDIR}/tbb41_${PRDATE}oss/" | ||
17 | |||
18 | SRC_URI[md5sum] = "3809790e1001a1b32d59c9fee590ee85" | ||
19 | SRC_URI[sha256sum] = "4ae2c10899e3b6ef2f686013ec5901fc658444ca90178efaca6014b0665c34b6" | ||
20 | |||
21 | do_compile() { | ||
22 | oe_runmake compiler=gcc arch=${HOST_ARCH} runtime=cc4 | ||
23 | } | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${includedir} ${D}${libdir}/pkgconfig | ||
27 | rm ${S}/include/tbb/index.html -f | ||
28 | cp -a ${S}/include/tbb ${D}${includedir} | ||
29 | install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir} | ||
30 | install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig | ||
31 | } | ||