diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-graphics/fontforge/fontforge_20141126.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20141126.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20141126.bb new file mode 100644 index 000000000..72020db92 --- /dev/null +++ b/meta-oe/recipes-graphics/fontforge/fontforge_20141126.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "A font editor" | ||
2 | HOMEPAGE = "http://fontforge.github.io/en-US/" | ||
3 | LICENSE = "GPLv3" | ||
4 | LIC_FILES_CHKSUM = " \ | ||
5 | file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \ | ||
6 | file://LICENSE;md5=71d636ba7678baa1573e1b531041386e \ | ||
7 | " | ||
8 | |||
9 | inherit autotools pkgconfig pythonnative | ||
10 | |||
11 | DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool" | ||
12 | DEPENDS_append_class-target = " libxi" | ||
13 | |||
14 | SRC_URI = "https://github.com/${BPN}/${BPN}/archive/${PV}.tar.gz" | ||
15 | SRC_URI[md5sum] = "0d6f5112c4e5689087339a94aceadf77" | ||
16 | SRC_URI[sha256sum] = "9c90c640023463c0b2b97b87575a014fcf44f688c3763f4cd136d3c267092106" | ||
17 | |||
18 | EXTRA_OECONF_append_class-native = " with_x=no --disable-python-extension --disable-python-scripting" | ||
19 | |||
20 | do_configure_prepend() { | ||
21 | currdir=`pwd` | ||
22 | cd ${S} | ||
23 | ./bootstrap --force | ||
24 | cd $currdir | ||
25 | } | ||
26 | |||
27 | EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -I${B}/uthash/src'" | ||
28 | |||
29 | PACKAGES =+ "${PN}-python-dbg ${PN}-python" | ||
30 | |||
31 | FILES_${PN} += " \ | ||
32 | ${datadir}/mime \ | ||
33 | ${datadir}/icons \ | ||
34 | " | ||
35 | |||
36 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${PN}/python" | ||
37 | FILES_${PN}-python-dbg = "${PYTHON_SITEPACKAGES_DIR}/.debug" | ||
38 | RDEPENDS_${PN}-python = "python" | ||
39 | |||
40 | # for e.g kde's oxygen-fonts | ||
41 | BBCLASSEXTEND = "native" | ||