summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service11
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb13
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service
new file mode 100644
index 000000000..495b131ff
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Cloud9 IDE
3ConditionPathExists=|/var/lib/cloud9
4
5[Service]
6Restart=always
7EnvironmentFile=-/etc/default/node
8ExecStart=/usr/bin/node4 /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
index 0c07b128b..9ae25bb65 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
@@ -3,11 +3,13 @@ HOMEPAGE = "http://c9.io"
3LICENSE = "GPLv3" 3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
5 5
6PR = "r2" 6PR = "r4"
7 7
8# Nodejs-native for node-waf, nodejs4-native for the headers 8# Nodejs-native for node-waf, nodejs4-native for the headers
9DEPENDS = "libxml2 nodejs-native nodejs4-native" 9DEPENDS = "libxml2 nodejs-native nodejs4-native"
10 10
11inherit systemd
12
11SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ 13SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
12 git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ 14 git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
13 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \ 15 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
@@ -33,6 +35,7 @@ SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
33 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \ 35 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \
34 file://index.js \ 36 file://index.js \
35 file://cloud9-avahi.service \ 37 file://cloud9-avahi.service \
38 file://cloud9.service \
36 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \ 39 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \
37 " 40 "
38 41
@@ -97,6 +100,9 @@ do_install () {
97 100
98 install -m 0755 -d ${D}${sysconfdir}/avahi/services/ 101 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
99 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ 102 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
103
104 install -d ${D}${systemd_unitdir}/system
105 install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system
100} 106}
101 107
102FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \ 108FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \
@@ -104,3 +110,8 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o
104 " 110 "
105 111
106RDEPENDS_${PN} = "nodejs4 nodejs gzip" 112RDEPENDS_${PN} = "nodejs4 nodejs gzip"
113
114RPROVIDES_${PN} += "${PN}-systemd"
115RREPLACES_${PN} += "${PN}-systemd"
116RCONFLICTS_${PN} += "${PN}-systemd"
117SYSTEMD_SERVICE_${PN} = "cloud9.service"