summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.0.35+2.0.36rc1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.0.35+2.0.36rc1.bb b/meta-oe/recipes-support/gd/gd_2.0.35+2.0.36rc1.bb
new file mode 100644
index 000000000..7660ad9bb
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.0.35+2.0.36rc1.bb
@@ -0,0 +1,24 @@
1SECTION = "libs"
2LICENSE = "GD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
4DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
5DEPENDS = "freetype libpng jpeg zlib"
6PR = "r4"
7
8SRC_URI = "http://www.libgd.org/releases/gd-2.0.36RC1.tar.gz"
9SRC_URI[md5sum] = "39ac48e6d5e0012a3bd2248a0102f209"
10SRC_URI[sha256sum] = "dd7c1795271221b9237769b96b8cec7fbdc5db7b8954d864ead51fc1296a6ac8"
11
12S = "${WORKDIR}/gd-2.0.36RC1"
13
14inherit autotools binconfig gettext
15
16EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
17 --with-png=${STAGING_LIBDIR}/.. \
18 --with-jpeg=${STAGING_LIBDIR}/.. \
19 --with-freetype \
20 --without-fontconfig \
21 --without-xpm \
22 --without-x"
23
24EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'