diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/gateone/gateone/gateone.service | 10 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/gateone/gateone_git.bb | 10 |
2 files changed, 18 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service new file mode 100644 index 000000000..7ff60020a --- /dev/null +++ b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=GateOne daemon | ||
3 | ConditionPathExists=|/var/lib/gateone | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=/var/lib/gateone | ||
7 | ExecStart=/usr/bin/python gateone.py | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb index e9c182da5..355200978 100644 --- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb +++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb | |||
@@ -2,18 +2,19 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client" | |||
2 | LICENSE = "AGPLv3" | 2 | LICENSE = "AGPLv3" |
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" | 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" |
4 | 4 | ||
5 | PR = "r10" | 5 | PR = "r13" |
6 | 6 | ||
7 | PV = "1.1" | 7 | PV = "1.1" |
8 | SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9" | 8 | SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9" |
9 | SRC_URI = "git://github.com/liftoff/GateOne.git \ | 9 | SRC_URI = "git://github.com/liftoff/GateOne.git \ |
10 | file://gateone-avahi.service \ | 10 | file://gateone-avahi.service \ |
11 | file://server.conf \ | 11 | file://server.conf \ |
12 | file://gateone.service \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
15 | 16 | ||
16 | inherit distutils allarch python-dir | 17 | inherit distutils allarch python-dir systemd |
17 | 18 | ||
18 | export prefix = "${localstatedir}/lib" | 19 | export prefix = "${localstatedir}/lib" |
19 | 20 | ||
@@ -24,6 +25,9 @@ do_install_append() { | |||
24 | install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ | 25 | install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ |
25 | 26 | ||
26 | install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf | 27 | install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf |
28 | |||
29 | install -d ${D}${systemd_unitdir}/system | ||
30 | install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system | ||
27 | } | 31 | } |
28 | 32 | ||
29 | FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" | 33 | FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" |
@@ -57,3 +61,5 @@ RDEPENDS_${PN} = "file \ | |||
57 | python-unixadmin \ | 61 | python-unixadmin \ |
58 | python-xml \ | 62 | python-xml \ |
59 | " | 63 | " |
64 | |||
65 | SYSTEMD_SERVICE_${PN} = "gateone.service" | ||