summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/jq/files/automake-once-fix.patch29
-rw-r--r--meta-oe/recipes-devtools/jq/jq_1.3.bb23
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jq/files/automake-once-fix.patch b/meta-oe/recipes-devtools/jq/files/automake-once-fix.patch
new file mode 100644
index 000000000..0a1d1a222
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/files/automake-once-fix.patch
@@ -0,0 +1,29 @@
1Upstream-Status: Applied
2https://github.com/stedolan/jq/commit/f0d1c39b5bbb4ccc517773eb635ba7f38ec7da1a
3
4Fixes build with automake-1.14
5
6diff --git a/configure.ac b/configure.ac
7index 76a49a9..d6d2d38 100644
8--- a/configure.ac
9+++ b/configure.ac
10@@ -4,7 +4,7 @@ AC_INIT([jq], [1.3], [mu@netsoc.tcd.ie],
11 dnl Created autoconf implementation thompson@dtosolutions, 26NOV12
12 AC_PREREQ([2.61])
13 AC_CONFIG_AUX_DIR([config])
14-AM_INIT_AUTOMAKE([parallel-tests foreign])
15+AM_INIT_AUTOMAKE([parallel-tests foreign -Wall])
16 AM_SILENT_RULES([yes])
17 AC_PROG_CC
18 AC_PROG_CC_STDC
19@@ -66,7 +66,6 @@ AC_SUBST([BUNDLER], ["$bundle_cmd"])
20
21 dnl AC_CONFIG_MACRO_DIR([m4])
22 AC_CONFIG_HEADERS(config.h)
23-AM_INIT_AUTOMAKE([-Wall])
24 AC_CONFIG_FILES([Makefile])
25 AC_OUTPUT
26
27--
281.8.5.4
29
diff --git a/meta-oe/recipes-devtools/jq/jq_1.3.bb b/meta-oe/recipes-devtools/jq/jq_1.3.bb
new file mode 100644
index 000000000..c58b47280
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/jq_1.3.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "http://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=244a1fb9cf472474a062d67069dec653"
11
12DEPENDS = "flex-native bison-native"
13
14SRC_URI = "http://stedolan.github.io/${BPN}/download/source/${BP}.tar.gz \
15 file://automake-once-fix.patch \
16"
17SRC_URI[md5sum] = "26081b05d22525eca5cbdd8f9f4db17d"
18SRC_URI[sha256sum] = "623f23c36abfc1d96d85020cf421b56f90a229d566f26a4a0d3e8536244bfed7"
19
20inherit autotools
21
22# Don't build documentation (generation requires ruby)
23EXTRA_OECONF = "--disable-docs"