diff options
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r-- | meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch | 46 | ||||
-rw-r--r-- | meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-test/catch2/catch2_2.5.0.bb (renamed from meta-oe/recipes-test/catch2/catch2_2.4.1.bb) | 16 |
3 files changed, 45 insertions, 53 deletions
diff --git a/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch b/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch deleted file mode 100644 index 307377563..000000000 --- a/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 5729874fa5059c39aa97cfa08fddf107b7a65c9e Mon Sep 17 00:00:00 2001 | ||
2 | From: Miguel Gaio <mgaio35@gmail.com> | ||
3 | Date: Wed, 3 Oct 2018 10:22:16 +0200 | ||
4 | Subject: [PATCH] Fix convert from char on ARM build | ||
5 | |||
6 | Some platforms set the signedness of char to unsigned (eg. ARM). | ||
7 | Convert from char should not assume the signedness of char. | ||
8 | |||
9 | Fix build issue with -Werror,-Wtautological-unsigned-zero-compare flags. | ||
10 | |||
11 | Signed-off-by: Miguel Gaio <mgaio35@gmail.com> | ||
12 | |||
13 | Upstream-Status: Accepted [Commit f1faaa9c107113692301ad8bb56084460ef1a2ff] | ||
14 | |||
15 | Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> | ||
16 | --- | ||
17 | include/internal/catch_tostring.cpp | 6 +++--- | ||
18 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
19 | |||
20 | diff --git a/include/internal/catch_tostring.cpp b/include/internal/catch_tostring.cpp | ||
21 | index 4e0c027d..8cbabbf2 100644 | ||
22 | --- a/include/internal/catch_tostring.cpp | ||
23 | +++ b/include/internal/catch_tostring.cpp | ||
24 | @@ -205,7 +205,7 @@ std::string StringMaker<bool>::convert(bool b) { | ||
25 | return b ? "true" : "false"; | ||
26 | } | ||
27 | |||
28 | -std::string StringMaker<char>::convert(char value) { | ||
29 | +std::string StringMaker<signed char>::convert(signed char value) { | ||
30 | if (value == '\r') { | ||
31 | return "'\\r'"; | ||
32 | } else if (value == '\f') { | ||
33 | @@ -222,8 +222,8 @@ std::string StringMaker<char>::convert(char value) { | ||
34 | return chstr; | ||
35 | } | ||
36 | } | ||
37 | -std::string StringMaker<signed char>::convert(signed char c) { | ||
38 | - return ::Catch::Detail::stringify(static_cast<char>(c)); | ||
39 | +std::string StringMaker<char>::convert(char c) { | ||
40 | + return ::Catch::Detail::stringify(static_cast<signed char>(c)); | ||
41 | } | ||
42 | std::string StringMaker<unsigned char>::convert(unsigned char c) { | ||
43 | return ::Catch::Detail::stringify(static_cast<char>(c)); | ||
44 | -- | ||
45 | 2.19.1 | ||
46 | |||
diff --git a/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch b/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch new file mode 100644 index 000000000..c3f5fc9ce --- /dev/null +++ b/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From b2bd82a0c0d3d5dda588d12cc1672a03a9630784 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 17 Dec 2018 17:27:43 -0800 | ||
4 | Subject: [PATCH] Remove redundant move | ||
5 | |||
6 | fixes errors like below | ||
7 | |||
8 | /mnt/a/yoe/build/tmp/work/aarch64-yoe-linux-musl/catch2/2.5.0-r0/git/include/internal/catch_session.cpp:52:29: | ||
9 | error: redundant move in return statement [-Werror=redundant-move] | ||
10 | 52 | return std::move(multi); | ||
11 | | ~~~~~~~~~^~~~~~~ | ||
12 | /mnt/a/yoe/build/tmp/work/aarch64-yoe-linux-musl/catch2/2.5.0-r0/git/include/internal/catch_session.cpp:52:29: | ||
13 | note: remove 'std::move' call | ||
14 | |||
15 | Upstream-Status: Submitted [https://github.com/catchorg/Catch2/pull/1474] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | include/internal/catch_session.cpp | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/include/internal/catch_session.cpp b/include/internal/catch_session.cpp | ||
22 | index 0920521c..b66d57ac 100644 | ||
23 | --- a/include/internal/catch_session.cpp | ||
24 | +++ b/include/internal/catch_session.cpp | ||
25 | @@ -49,7 +49,7 @@ namespace Catch { | ||
26 | multi->addListener(listener->create(Catch::ReporterConfig(config))); | ||
27 | } | ||
28 | multi->addReporter(createReporter(config->getReporterName(), config)); | ||
29 | - return std::move(multi); | ||
30 | + return multi; | ||
31 | } | ||
32 | |||
33 | |||
34 | -- | ||
35 | 2.20.1 | ||
36 | |||
diff --git a/meta-oe/recipes-test/catch2/catch2_2.4.1.bb b/meta-oe/recipes-test/catch2/catch2_2.5.0.bb index 0183c2e41..14a1ebe80 100644 --- a/meta-oe/recipes-test/catch2/catch2_2.4.1.bb +++ b/meta-oe/recipes-test/catch2/catch2_2.5.0.bb | |||
@@ -6,19 +6,21 @@ LICENSE = "BSL-1.0" | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
7 | 7 | ||
8 | SRC_URI = "git://github.com/catchorg/Catch2.git \ | 8 | SRC_URI = "git://github.com/catchorg/Catch2.git \ |
9 | file://0001-Fix-convert-from-char-on-ARM-build.patch" | 9 | file://0001-Remove-redundant-move.patch \ |
10 | SRCREV = "9e1bdca4667295fcb16265eae00efa8423f07007" | 10 | " |
11 | # v2.5.0 | ||
12 | SRCREV = "6ccd467094973824d89efb16cbc553e279f79823" | ||
11 | 13 | ||
12 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
13 | 15 | ||
14 | inherit cmake python3native | 16 | inherit cmake python3native |
15 | 17 | ||
18 | do_install_append() { | ||
19 | rm ${D}${datadir}/Catch2/lldbinit | ||
20 | rm ${D}${datadir}/Catch2/gdbinit | ||
21 | rmdir ${D}${datadir}/Catch2/ | ||
22 | } | ||
16 | # Header-only library | 23 | # Header-only library |
17 | RDEPENDS_${PN}-dev = "" | 24 | RDEPENDS_${PN}-dev = "" |
18 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" | 25 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |
19 | 26 | ||
20 | do_install_append() { | ||
21 | rm ${D}/${datadir}/Catch2/lldbinit | ||
22 | rm ${D}/${datadir}/Catch2/gdbinit | ||
23 | rmdir ${D}/${datadir}/Catch2/ | ||
24 | } | ||