summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch')
-rw-r--r--meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch b/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
deleted file mode 100644
index 0c160b02a..000000000
--- a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 5318983562be6babeb5a6996e7dda4b31acfdba8 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Wed, 30 Jul 2014 16:49:53 -0300
4Subject: [PATCH] cmake: Add install command for libraries and headers
5Organization: O.S. Systems Software LTDA.
6
7Upstream-Status: Inappropriate [embedded specific]
8
9Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
10---
11 CMakeLists.txt | 5 +++++
12 1 file changed, 5 insertions(+)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index 57470c8..281c4c2 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -56,6 +56,8 @@ include_directories(
19 ${gtest_SOURCE_DIR}/include
20 ${gtest_SOURCE_DIR})
21
22+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest DESTINATION include)
23+
24 # Where Google Test's libraries can be found.
25 link_directories(${gtest_BINARY_DIR}/src)
26
27@@ -71,6 +73,9 @@ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
28 cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
29 target_link_libraries(gtest_main gtest)
30
31+install(TARGETS gtest DESTINATION lib)
32+install(TARGETS gtest_main DESTINATION lib)
33+
34 ########################################################################
35 #
36 # Samples on how to link user tests with gtest or gtest_main.
37--
381.9.1
39