summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch')
-rw-r--r--meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch b/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
new file mode 100644
index 000000000..7a19f726f
--- /dev/null
+++ b/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
@@ -0,0 +1,55 @@
1From 89639e76d5ee039a55004e5e910d565e6e84ed35 Mon Sep 17 00:00:00 2001
2From: Rodrigo Caimi <caimi@datacom.ind.br>
3Date: Tue, 7 Oct 2014 15:37:10 -0300
4Subject: [PATCH 2/2] CMakeLists, gtest.pc.in: Add pkg-config support to gtest
5 1.7.0
6
7Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
8---
9 CMakeLists.txt | 6 ++++++
10 gtest.pc.in | 9 +++++++++
11 2 files changed, 15 insertions(+)
12 create mode 100644 gtest.pc.in
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index e969648..0038826 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -29,6 +29,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
19 pre_project_set_up_hermetic_build()
20 endif()
21
22+# pkg-config support
23+configure_file("gtest.pc.in" "gtest.pc" @ONLY)
24+
25 ########################################################################
26 #
27 # Project-wide settings
28@@ -78,6 +81,9 @@ install(TARGETS gtest gtest_main
29 DESTINATION ${CMAKE_INSTALL_LIBDIR})
30 install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
31 DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
32+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc"
33+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/"
34+)
35
36 ########################################################################
37 #
38diff --git a/gtest.pc.in b/gtest.pc.in
39new file mode 100644
40index 0000000..52e622b
41--- /dev/null
42+++ b/gtest.pc.in
43@@ -0,0 +1,9 @@
44+Name: libgtest
45+Version: 1.7.0
46+Description: Google's framework for writing C++ tests on a variety of platforms
47+
48+prefix=@CMAKE_INSTALL_PREFIX@
49+includedir=@CMAKE_INSTALL_INCLUDEDIR@
50+libdir=@CMAKE_INSTALL_LIBDIR@
51+Cflags:-I${includedir}/gtest
52+Libs: -L${libdir} -lgtest -lgtest_main
53--
542.5.0
55