diff options
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.2/787.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.2/boost-fix.patch | 14 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/732.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/747.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-float-tests.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-outside-tests.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-test-timeouts.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch) | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb | 23 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb | 22 |
10 files changed, 23 insertions, 70 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/787.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/787.patch deleted file mode 100644 index 359a3ba526..0000000000 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/787.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 212536f9d66400bef4400c55efd05dd01303c035 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andreas Stieger <astieger@suse.com> | ||
3 | Date: Sun, 17 Jun 2018 13:00:05 +0200 | ||
4 | Subject: [PATCH] Fix gcc8 error/warning -Werror=format-truncation= | ||
5 | |||
6 | utilities::datetime::to_string(): datetime_str and buf were oversized | ||
7 | for fitting into output without possible trunctation | ||
8 | --- | ||
9 | Release/src/utilities/asyncrt_utils.cpp | 7 ++++--- | ||
10 | 1 file changed, 4 insertions(+), 3 deletions(-) | ||
11 | |||
12 | diff --git a/Release/src/utilities/asyncrt_utils.cpp b/Release/src/utilities/asyncrt_utils.cpp | ||
13 | index 0e62bdee..be38907c 100644 | ||
14 | --- a/Release/src/utilities/asyncrt_utils.cpp | ||
15 | +++ b/Release/src/utilities/asyncrt_utils.cpp | ||
16 | @@ -691,12 +691,13 @@ utility::string_t datetime::to_string(date_format format) const | ||
17 | { | ||
18 | // Append fractional second, which is a 7-digit value with no trailing zeros | ||
19 | // This way, '1200' becomes '00012' | ||
20 | - char buf[9] = { 0 }; | ||
21 | + const int max_frac_length = 8; | ||
22 | + char buf[max_frac_length+1] = { 0 }; | ||
23 | snprintf(buf, sizeof(buf), ".%07ld", (long int)frac_sec); | ||
24 | // trim trailing zeros | ||
25 | - for (int i = 7; buf[i] == '0'; i--) buf[i] = '\0'; | ||
26 | + for (int i = max_frac_length-1; buf[i] == '0'; i--) buf[i] = '\0'; | ||
27 | // format the datetime into a separate buffer | ||
28 | - char datetime_str[max_dt_length+1] = {0}; | ||
29 | + char datetime_str[max_dt_length-max_frac_length-1+1] = {0}; | ||
30 | strftime(datetime_str, sizeof(datetime_str), "%Y-%m-%dT%H:%M:%S", &datetime); | ||
31 | // now print this buffer into the output buffer | ||
32 | snprintf(output, sizeof(output), "%s%sZ", datetime_str, buf); | ||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/boost-fix.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/boost-fix.patch deleted file mode 100644 index 5318a6a103..0000000000 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/boost-fix.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | Origin: https://github.com/Microsoft/cpprestsdk/issues/813 | ||
2 | Last-Update: 2018-07-23 | ||
3 | |||
4 | --- cpprest-2.10.2.orig/Release/libs/websocketpp/websocketpp/transport/asio/security/tls.hpp | ||
5 | +++ cpprest-2.10.2/Release/libs/websocketpp/websocketpp/transport/asio/security/tls.hpp | ||
6 | @@ -312,7 +312,7 @@ protected: | ||
7 | return make_error_code(transport::error::tls_short_read); | ||
8 | #else | ||
9 | if (ERR_GET_REASON(ec.value()) == boost::asio::ssl::error::stream_truncated) { | ||
10 | - return make_error_code(boost::asio::ssl::error::stream_truncated); | ||
11 | + return make_error_code(static_cast<std::errc>(boost::asio::ssl::error::stream_truncated)); | ||
12 | #endif | ||
13 | } else { | ||
14 | // We know it is a TLS related error, but otherwise don't know | ||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/732.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch index 9fcffbfed2..9fcffbfed2 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/732.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/747.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch index 94bb005989..94bb005989 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/747.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-float-tests.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch index 75f74ec658..75f74ec658 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-float-tests.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch index b9b3591c3a..b9b3591c3a 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-outside-tests.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-test-timeouts.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch index 93c3e8a269..93c3e8a269 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/disable-test-timeouts.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch index ab92276804..4d03e6d282 100644 --- a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch | |||
@@ -30,7 +30,7 @@ Index: cpprest/Release/src/CMakeLists.txt | |||
30 | =================================================================== | 30 | =================================================================== |
31 | --- cpprest.orig/Release/src/CMakeLists.txt | 31 | --- cpprest.orig/Release/src/CMakeLists.txt |
32 | +++ cpprest/Release/src/CMakeLists.txt | 32 | +++ cpprest/Release/src/CMakeLists.txt |
33 | @@ -250,21 +250,21 @@ | 33 | @@ -253,21 +253,21 @@ |
34 | install( | 34 | install( |
35 | TARGETS ${CPPREST_TARGETS} | 35 | TARGETS ${CPPREST_TARGETS} |
36 | EXPORT cpprestsdk-targets | 36 | EXPORT cpprestsdk-targets |
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb deleted file mode 100644 index 47183c5766..0000000000 --- a/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design." | ||
2 | SECTION = "libs/network" | ||
3 | HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/../license.txt;md5=a2e15b954769218ff912468eecd6a02f" | ||
6 | DEPENDS = "openssl websocketpp zlib boost" | ||
7 | |||
8 | SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \ | ||
9 | file://disable-outside-tests.patch;patchdir=.. \ | ||
10 | file://disable-test-timeouts.patch;patchdir=.. \ | ||
11 | file://disable-float-tests.patch;patchdir=.. \ | ||
12 | file://fix-cmake-install.patch;patchdir=.. \ | ||
13 | file://747.patch;patchdir=.. \ | ||
14 | file://732.patch;patchdir=.. \ | ||
15 | file://787.patch;patchdir=.. \ | ||
16 | " | ||
17 | |||
18 | # tag 2.10.2 | ||
19 | SRCREV= "fea848e2a77563cf2a6f28f8eab396fd6e787fbf" | ||
20 | |||
21 | S = "${WORKDIR}/git/Release" | ||
22 | |||
23 | inherit cmake | ||
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb new file mode 100644 index 0000000000..addacbbd25 --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design." | ||
2 | SECTION = "libs/network" | ||
3 | HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f" | ||
6 | DEPENDS = "openssl websocketpp zlib boost" | ||
7 | |||
8 | SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \ | ||
9 | file://disable-outside-tests.patch \ | ||
10 | file://disable-test-timeouts.patch \ | ||
11 | file://disable-float-tests.patch \ | ||
12 | file://fix-cmake-install.patch \ | ||
13 | file://747.patch \ | ||
14 | file://732.patch \ | ||
15 | " | ||
16 | |||
17 | # tag 2.10.3 | ||
18 | SRCREV= "e388a2e523f4d0b6aee2bb923637d82d8b969556" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | inherit cmake | ||