diff options
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest/950-fix.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest/system-brotli.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb (renamed from meta-oe/recipes-support/cpprest/cpprest_2.10.7.bb) | 6 |
3 files changed, 2 insertions, 68 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest/950-fix.patch b/meta-oe/recipes-support/cpprest/cpprest/950-fix.patch deleted file mode 100644 index 3ae46a115..000000000 --- a/meta-oe/recipes-support/cpprest/cpprest/950-fix.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | Origin: upstream | ||
2 | Bug: https://github.com/Microsoft/cpprestsdk/issues/950 | ||
3 | Last-Update: 2018-11-04 | ||
4 | |||
5 | Index: cpprest/Release/src/utilities/asyncrt_utils.cpp | ||
6 | =================================================================== | ||
7 | --- cpprest.orig/Release/src/utilities/asyncrt_utils.cpp | ||
8 | +++ cpprest/Release/src/utilities/asyncrt_utils.cpp | ||
9 | @@ -356,7 +356,7 @@ | ||
10 | inline size_t count_utf8_to_utf16(const std::string& s) | ||
11 | { | ||
12 | const size_t sSize = s.size(); | ||
13 | - auto sData = reinterpret_cast<const UtilCharInternal_t* const>(s.data()); | ||
14 | + auto const sData = reinterpret_cast<const UtilCharInternal_t*>(s.data()); | ||
15 | size_t result{ sSize }; | ||
16 | |||
17 | for (size_t index = 0; index < sSize;) | ||
18 | @@ -441,7 +441,7 @@ | ||
19 | { | ||
20 | // Save repeated heap allocations, use the length of resulting sequence. | ||
21 | const size_t srcSize = s.size(); | ||
22 | - auto srcData = reinterpret_cast<const UtilCharInternal_t* const>(s.data()); | ||
23 | + auto const srcData = reinterpret_cast<const UtilCharInternal_t*>(s.data()); | ||
24 | utf16string dest(count_utf8_to_utf16(s), L'\0'); | ||
25 | utf16string::value_type* const destData = &dest[0]; | ||
26 | size_t destIndex = 0; | ||
diff --git a/meta-oe/recipes-support/cpprest/cpprest/system-brotli.patch b/meta-oe/recipes-support/cpprest/cpprest/system-brotli.patch deleted file mode 100644 index e6f64772d..000000000 --- a/meta-oe/recipes-support/cpprest/cpprest/system-brotli.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | Description: Find system brotli | ||
2 | Author: Gianfranco Costamagna <locutusofborg@debian.org> | ||
3 | Forwarded: https://github.com/Microsoft/cpprestsdk/pull/952 | ||
4 | Last-Update: 2018-11-05 | ||
5 | |||
6 | --- cpprest-2.10.7.orig/Release/cmake/cpprest_find_brotli.cmake | ||
7 | +++ cpprest-2.10.7/Release/cmake/cpprest_find_brotli.cmake | ||
8 | @@ -3,8 +3,17 @@ function(cpprest_find_brotli) | ||
9 | return() | ||
10 | endif() | ||
11 | |||
12 | - find_package(unofficial-brotli REQUIRED) | ||
13 | |||
14 | - add_library(cpprestsdk_brotli_internal INTERFACE) | ||
15 | - target_link_libraries(cpprestsdk_brotli_internal INTERFACE unofficial::brotli::brotlienc unofficial::brotli::brotlidec unofficial::brotli::brotlicommon) | ||
16 | + find_package(PkgConfig) | ||
17 | + pkg_check_modules(BROTLIENC libbrotlienc) | ||
18 | + pkg_check_modules(BROTLIDEC libbrotlidec) | ||
19 | + if(BROTLIDEC_FOUND AND BROTLIENC_FOUND) | ||
20 | + target_link_libraries(cpprest PRIVATE ${BROTLIDEC_LDFLAGS} ${BROTLIENC_LDFLAGS}) | ||
21 | + else(BROTLIDEC_FOUND AND BROTLIENC_FOUND) | ||
22 | + find_package(unofficial-brotli REQUIRED) | ||
23 | + add_library(cpprestsdk_brotli_internal INTERFACE) | ||
24 | + target_link_libraries(cpprestsdk_brotli_internal INTERFACE unofficial::brotli::brotlienc unofficial::brotli::brotlidec unofficial::brotli::brotlicommon) | ||
25 | + target_link_libraries(cpprest PRIVATE cpprestsdk_brotli_internal) | ||
26 | + endif(BROTLIDEC_FOUND AND BROTLIENC_FOUND) | ||
27 | + | ||
28 | endfunction() | ||
29 | --- cpprest-2.10.7.orig/Release/src/CMakeLists.txt | ||
30 | +++ cpprest-2.10.7/Release/src/CMakeLists.txt | ||
31 | @@ -84,7 +84,6 @@ else() | ||
32 | target_compile_definitions(cpprest PRIVATE -DCPPREST_EXCLUDE_BROTLI=1) | ||
33 | else() | ||
34 | cpprest_find_brotli() | ||
35 | - target_link_libraries(cpprest PRIVATE cpprestsdk_brotli_internal) | ||
36 | endif() | ||
37 | endif() | ||
38 | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.7.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb index 5cc6385df..c94038f8f 100644 --- a/meta-oe/recipes-support/cpprest/cpprest_2.10.7.bb +++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb | |||
@@ -11,12 +11,10 @@ SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=maste | |||
11 | file://disable-outside-tests.patch \ | 11 | file://disable-outside-tests.patch \ |
12 | file://disable-test-timeouts.patch \ | 12 | file://disable-test-timeouts.patch \ |
13 | file://disable-float-tests.patch \ | 13 | file://disable-float-tests.patch \ |
14 | file://950-fix.patch \ | ||
15 | file://system-brotli.patch \ | ||
16 | " | 14 | " |
17 | 15 | ||
18 | # tag 2.10.7 | 16 | # tag 2.10.8 |
19 | SRCREV= "c4cef129e880a3f9c23a480e8c983793963173bb" | 17 | SRCREV= "204a52610234ac5180e80a6883b62c0ad085f51e" |
20 | 18 | ||
21 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
22 | 20 | ||