diff options
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch | 17 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb | 17 |
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch new file mode 100644 index 000000000..0feafef5b --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Description: install cmake files into /usr/lib/cmake/cpprestsdk | ||
2 | Author: Gianfranco Costamagna <locutusofborg@debian.org> | ||
3 | Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737 | ||
4 | Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737 | ||
5 | Last-Update: 2018-04-19 | ||
6 | |||
7 | --- cpprest-2.10.2.orig/CMakeLists.txt | ||
8 | +++ cpprest-2.10.2/CMakeLists.txt | ||
9 | @@ -18,7 +18,7 @@ enable_testing() | ||
10 | set(WERROR ON CACHE BOOL "Treat Warnings as Errors.") | ||
11 | set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.") | ||
12 | set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.") | ||
13 | -set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.") | ||
14 | +set(CPPREST_EXPORT_DIR lib/cmake/cpprestsdk CACHE STRING "Directory to install CMake config files.") | ||
15 | set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.") | ||
16 | set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.") | ||
17 | |||
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb new file mode 100644 index 000000000..2ba6fc66c --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design." | ||
2 | SECTION = "libs/network" | ||
3 | HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/../license.txt;md5=a2e15b954769218ff912468eecd6a02f" | ||
6 | DEPENDS = "openssl websocketpp zlib boost" | ||
7 | |||
8 | SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master" | ||
9 | |||
10 | SRC_URI += "file://fix-cmake-install.patch" | ||
11 | |||
12 | # tag 2.10.2 | ||
13 | SRCREV= "fea848e2a77563cf2a6f28f8eab396fd6e787fbf" | ||
14 | |||
15 | S = "${WORKDIR}/git/Release" | ||
16 | |||
17 | inherit cmake | ||