summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch')
-rw-r--r--meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch b/meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch
new file mode 100644
index 000000000..e55f4f3b1
--- /dev/null
+++ b/meta-oe/recipes-support/xmlstarlet/files/configure.ac.patch
@@ -0,0 +1,28 @@
1configure.ac: don't use xml-config if --with-libxml-prefix is specified to configure
2
3Same behavior for xslt-config.
4
5diff --git a/configure.ac b/configure.ac
6index ed04e0c..39d5d4c 100644
7--- a/configure.ac
8+++ b/configure.ac
9@@ -40,7 +40,8 @@ AC_ARG_PROGRAM dnl Transforming Program Names When Installing
10 AC_PROG_SED
11 AC_PROG_AWK
12
13-XSTAR_LIB_CHECK([LIBXML], [xml2-config])
14+AS_IF([test "x$LIBXML_PREFIX" = x],
15+ [XSTAR_LIB_CHECK([LIBXML], [xml2-config])])
16
17 AS_IF([test "x$LIBXML_SRCDIR" != x],
18 [LIBXML_INCDIR="$LIBXML_SRCDIR/include"])
19@@ -56,7 +57,8 @@ AS_IF([test "x$STATIC_LIBS" != xno],
20 [LIBXML_LDFLAGS="-L$LIBXML_LIBDIR"]
21
22
23-XSTAR_LIB_CHECK([LIBXSLT], [xslt-config])
24+AS_IF([test "x$LIBXSLT_PREFIX" = x],
25+ [XSTAR_LIB_CHECK([LIBXSLT], [xslt-config])])
26
27 AS_IF([test "x$LIBXSLT_SRCDIR" != x],
28 [XSLTPROC_PATH="$LIBXSLT_SRCDIR/xsltproc:$PATH"