summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch')
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
new file mode 100644
index 000000000..a1ee627b3
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
@@ -0,0 +1,23 @@
1From 3590d77bb9753fbbf076028e2395182ced6466ba Mon Sep 17 00:00:00 2001
2From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
3Date: Wed, 8 Jan 2020 17:59:48 +0100
4Subject: [PATCH] Fix cmake find boost with version >= 1.71
5
6For some reasons "system;thread;random;unit_test_framework" was seen as a single module, because of the quotes.
7---
8 CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 2d13117b..9a46bc10 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -213,7 +213,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
16 set (Boost_USE_MULTITHREADED TRUE)
17 set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
18
19- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
20+ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
21
22 if (Boost_FOUND)
23 # Boost is a project wide global dependency.