diff options
Diffstat (limited to 'meta-oe/recipes-support/vim/vim_7.4.481.bb')
-rw-r--r-- | meta-oe/recipes-support/vim/vim_7.4.481.bb | 103 |
1 files changed, 103 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.481.bb b/meta-oe/recipes-support/vim/vim_7.4.481.bb new file mode 100644 index 000000000..b85ff63d5 --- /dev/null +++ b/meta-oe/recipes-support/vim/vim_7.4.481.bb | |||
@@ -0,0 +1,103 @@ | |||
1 | SUMMARY = "Vi IMproved - enhanced vi editor" | ||
2 | SECTION = "console/utils" | ||
3 | DEPENDS = "ncurses gettext-native" | ||
4 | # vimdiff doesn't like busybox diff | ||
5 | RSUGGESTS_${PN} = "diffutils" | ||
6 | LICENSE = "vim" | ||
7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" | ||
8 | |||
9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \ | ||
10 | file://disable_acl_header_check.patch;patchdir=.. \ | ||
11 | file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ | ||
12 | " | ||
13 | SRCREV = "v7-4-481" | ||
14 | |||
15 | S = "${WORKDIR}/${BPN}/src" | ||
16 | |||
17 | VIMDIR = "${BPN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" | ||
18 | |||
19 | inherit autotools update-alternatives | ||
20 | inherit autotools-brokensep | ||
21 | |||
22 | # vim configure.in contains functions which got 'dropped' by autotools.bbclass | ||
23 | do_configure () { | ||
24 | rm -f auto/* | ||
25 | touch auto/config.mk | ||
26 | aclocal | ||
27 | autoconf | ||
28 | oe_runconf | ||
29 | touch auto/configure | ||
30 | touch auto/config.mk auto/config.h | ||
31 | } | ||
32 | |||
33 | #Available PACKAGECONFIG options are gtkgui, acl, x11, tiny | ||
34 | PACKAGECONFIG ??= "" | ||
35 | PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}" | ||
36 | PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" | ||
37 | |||
38 | PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+," | ||
39 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," | ||
40 | PACKAGECONFIG[x11] = "--with-x,--without-x,xt," | ||
41 | PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,," | ||
42 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux," | ||
43 | PACKAGECONFIG[elfutils] = "--enable-elf-check,,elfutils," | ||
44 | |||
45 | EXTRA_OECONF = " \ | ||
46 | --disable-gpm \ | ||
47 | --disable-gtktest \ | ||
48 | --disable-xim \ | ||
49 | --disable-netbeans \ | ||
50 | --with-tlib=ncurses \ | ||
51 | ac_cv_small_wchar_t=no \ | ||
52 | vim_cv_getcwd_broken=no \ | ||
53 | vim_cv_memmove_handles_overlap=yes \ | ||
54 | vim_cv_stat_ignores_slash=no \ | ||
55 | vim_cv_terminfo=yes \ | ||
56 | vim_cv_tgent=non-zero \ | ||
57 | vim_cv_toupper_broken=no \ | ||
58 | vim_cv_tty_group=world \ | ||
59 | STRIP=/bin/true \ | ||
60 | " | ||
61 | |||
62 | do_install_append() { | ||
63 | # Work around rpm picking up csh or awk or perl as a dep | ||
64 | chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132 | ||
65 | chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk | ||
66 | chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.pl | ||
67 | |||
68 | # Install example vimrc from runtime files | ||
69 | install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc | ||
70 | } | ||
71 | |||
72 | PARALLEL_MAKEINST = "" | ||
73 | |||
74 | PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc" | ||
75 | FILES_${PN}-syntax = "${datadir}/${BPN}/${VIMDIR}/syntax" | ||
76 | FILES_${PN}-help = "${datadir}/${BPN}/${VIMDIR}/doc" | ||
77 | FILES_${PN}-tutor = "${datadir}/${BPN}/${VIMDIR}/tutor ${bindir}/${BPN}tutor" | ||
78 | FILES_${PN}-vimrc = "${datadir}/${BPN}/vimrc" | ||
79 | FILES_${PN}-data = "${datadir}/${BPN}" | ||
80 | FILES_${PN}-common = " \ | ||
81 | ${datadir}/${BPN}/${VIMDIR}/*.vim \ | ||
82 | ${datadir}/${BPN}/${VIMDIR}/autoload \ | ||
83 | ${datadir}/${BPN}/${VIMDIR}/colors \ | ||
84 | ${datadir}/${BPN}/${VIMDIR}/compiler \ | ||
85 | ${datadir}/${BPN}/${VIMDIR}/ftplugin \ | ||
86 | ${datadir}/${BPN}/${VIMDIR}/indent \ | ||
87 | ${datadir}/${BPN}/${VIMDIR}/keymap \ | ||
88 | ${datadir}/${BPN}/${VIMDIR}/lang \ | ||
89 | ${datadir}/${BPN}/${VIMDIR}/macros \ | ||
90 | ${datadir}/${BPN}/${VIMDIR}/plugin \ | ||
91 | ${datadir}/${BPN}/${VIMDIR}/print \ | ||
92 | ${datadir}/${BPN}/${VIMDIR}/spell \ | ||
93 | ${datadir}/${BPN}/${VIMDIR}/tools \ | ||
94 | " | ||
95 | |||
96 | RDEPENDS_${PN} = "ncurses-terminfo-base" | ||
97 | # Recommend that runtime data is installed along with vim | ||
98 | RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common" | ||
99 | |||
100 | ALTERNATIVE_${PN} = "vi" | ||
101 | ALTERNATIVE_TARGET[vi] = "${bindir}/${BPN}" | ||
102 | ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi" | ||
103 | ALTERNATIVE_PRIORITY[vi] = "100" | ||