summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim/vim.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/vim/vim.inc')
-rw-r--r--meta-oe/recipes-support/vim/vim.inc52
1 files changed, 26 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/vim/vim.inc b/meta-oe/recipes-support/vim/vim.inc
index 4fa8f7cad..e288fff28 100644
--- a/meta-oe/recipes-support/vim/vim.inc
+++ b/meta-oe/recipes-support/vim/vim.inc
@@ -12,10 +12,10 @@ VIMDIR = "${PN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[
12INC_PR = "r13" 12INC_PR = "r13"
13 13
14SRC_URI = " \ 14SRC_URI = " \
15 ftp://ftp.${PN}.org/pub/${PN}/unix/${PN}-${PV_MAJOR}.tar.bz2;name=${VIMDIR} \ 15 ftp://ftp.${PN}.org/pub/${PN}/unix/${PN}-${PV_MAJOR}.tar.bz2;name=${VIMDIR} \
16 ftp://ftp.${PN}.org/pub/${PN}/extra/${PN}-${PV_MAJOR}-extra.tar.gz;name=${VIMDIR}-extra \ 16 ftp://ftp.${PN}.org/pub/${PN}/extra/${PN}-${PV_MAJOR}-extra.tar.gz;name=${VIMDIR}-extra \
17 ftp://ftp.${PN}.org/pub/${PN}/extra/${PN}-${PV_MAJOR}-lang.tar.gz;name=${VIMDIR}-lang \ 17 ftp://ftp.${PN}.org/pub/${PN}/extra/${PN}-${PV_MAJOR}-lang.tar.gz;name=${VIMDIR}-lang \
18 file://vimrc \ 18 file://vimrc \
19" 19"
20 20
21S = "${WORKDIR}/${VIMDIR}/src" 21S = "${WORKDIR}/${VIMDIR}/src"
@@ -24,13 +24,13 @@ inherit autotools update-alternatives
24 24
25# vim configure.in contains functions which got 'dropped' by autotools.bbclass 25# vim configure.in contains functions which got 'dropped' by autotools.bbclass
26do_configure () { 26do_configure () {
27 rm -f auto/* 27 rm -f auto/*
28 touch auto/config.mk 28 touch auto/config.mk
29 aclocal 29 aclocal
30 autoconf 30 autoconf
31 oe_runconf 31 oe_runconf
32 touch auto/configure 32 touch auto/configure
33 touch auto/config.mk auto/config.h 33 touch auto/config.mk auto/config.h
34} 34}
35 35
36#Available PACKAGECONFIG options are gtkgui, x11, tiny 36#Available PACKAGECONFIG options are gtkgui, x11, tiny
@@ -41,25 +41,25 @@ PACKAGECONFIG[x11] = "--with-x,--without-x,xt,"
41PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,," 41PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,,"
42 42
43EXTRA_OECONF = " \ 43EXTRA_OECONF = " \
44 --disable-gpm \ 44 --disable-gpm \
45 --disable-gtktest \ 45 --disable-gtktest \
46 --disable-xim \ 46 --disable-xim \
47 --disable-netbeans \ 47 --disable-netbeans \
48 --with-tlib=ncurses \ 48 --with-tlib=ncurses \
49 ac_cv_small_wchar_t=no \ 49 ac_cv_small_wchar_t=no \
50 vim_cv_getcwd_broken=no \ 50 vim_cv_getcwd_broken=no \
51 vim_cv_memmove_handles_overlap=yes \ 51 vim_cv_memmove_handles_overlap=yes \
52 vim_cv_stat_ignores_slash=no \ 52 vim_cv_stat_ignores_slash=no \
53 vim_cv_terminfo=yes \ 53 vim_cv_terminfo=yes \
54 vim_cv_tgent=non-zero \ 54 vim_cv_tgent=non-zero \
55 vim_cv_toupper_broken=no \ 55 vim_cv_toupper_broken=no \
56 vim_cv_tty_group=world \ 56 vim_cv_tty_group=world \
57" 57"
58 58
59# Work around rpm picking up csh as a dep 59# Work around rpm picking up csh as a dep
60do_install_append() { 60do_install_append() {
61 chmod -x ${D}${datadir}/${PN}/${VIMDIR}/tools/vim132 61 chmod -x ${D}${datadir}/${PN}/${VIMDIR}/tools/vim132
62 install -m 0644 ${WORKDIR}/vimrc ${D}/${datadir}/${PN} 62 install -m 0644 ${WORKDIR}/vimrc ${D}/${datadir}/${PN}
63} 63}
64 64
65PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data" 65PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data"