summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uhubctl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/uhubctl')
-rw-r--r--meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb b/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb
new file mode 100644
index 000000000..6306ddb55
--- /dev/null
+++ b/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "USB hub per-port power control"
2HOMEPAGE = "https://github.com/mvp/uhubctl"
3BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
4DEPENDS = "libusb1"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "https://github.com/mvp/${PN}/archive/v${PV}.tar.gz"
10SRC_URI[md5sum] = "5c711911d766d76813333c3812277574"
11SRC_URI[sha256sum] = "4c31278b2c03e5be5a696c3088bc86cf2557a70e00f697799c163aba18e3c40e"
12
13# uhubctl gets its program version from "git describe". As we use the source
14# archive do reduce download size replace the call with our hardcoded version.
15do_configure_append() {
16 sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
17}
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}