diff options
Diffstat (limited to 'meta-oe/recipes-support/tokyocabinet')
-rw-r--r-- | meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb | 27 |
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch b/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch new file mode 100644 index 000000000..a8ab23de7 --- /dev/null +++ b/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Upstream-Status: Inappropriate [embedded specific] | ||
2 | |||
3 | There are hardcode paths in configure.in eg: /usr/include, $HOME/include etc. | ||
4 | These paths will cause Makefile to search host path when doing cross-compiling. | ||
5 | and bitbake will prompt this as an error. So remove them. | ||
6 | |||
7 | Signed-off-by: Song.Li <Song.Li@windriver.com> | ||
8 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
9 | --- | ||
10 | configure.in | 10 ++-------- | ||
11 | 1 file changed, 2 insertions(+), 8 deletions(-) | ||
12 | |||
13 | diff --git a/configure.in b/configure.in | ||
14 | index bcfd5bc..5b24947 100644 | ||
15 | --- a/configure.in | ||
16 | +++ b/configure.in | ||
17 | @@ -32,21 +32,15 @@ MYPCFILES="tokyocabinet.pc" | ||
18 | |||
19 | # Building flags | ||
20 | MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2" | ||
21 | -MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include" | ||
22 | +MYCPPFLAGS="-I." | ||
23 | MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1 -D_REENTRANT -D__EXTENSIONS__" | ||
24 | -MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib" | ||
25 | +MYLDFLAGS="-L." | ||
26 | MYCMDLDFLAGS="" | ||
27 | MYRUNPATH="\$(LIBDIR)" | ||
28 | MYLDLIBPATHENV="LD_LIBRARY_PATH" | ||
29 | MYPOSTCMD="true" | ||
30 | |||
31 | # Building paths | ||
32 | -PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin" | ||
33 | -PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb" | ||
34 | -CPATH="$HOME/include:/usr/local/include:$CPATH" | ||
35 | -LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH" | ||
36 | -LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH" | ||
37 | -PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH" | ||
38 | export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH | ||
39 | |||
40 | |||
41 | -- | ||
42 | 1.7.9.5 | ||
43 | |||
diff --git a/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb b/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb new file mode 100644 index 000000000..9f75cf047 --- /dev/null +++ b/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | # | ||
2 | # Copyright (C) 2012 - 2016 Wind River Systems, Inc. | ||
3 | # | ||
4 | SUMMARY = "A modern implementation of DBM" | ||
5 | |||
6 | DESCRIPTION = "Tokyo Cabinet is a library of routines for managing a database. \ | ||
7 | The database is a simple data file containing records, each is a pair of a key \ | ||
8 | and a value. Every key and value is serial bytes with variable length. \ | ||
9 | Both binary data and character string can be used as a key and a value. \ | ||
10 | There is neither concept of data tables nor data types. \ | ||
11 | Records are organized in hash table, B+ tree, or fixed-length array." | ||
12 | |||
13 | HOMEPAGE = "http://fallabs.com/tokyocabinet/" | ||
14 | |||
15 | LICENSE = "GPLv2" | ||
16 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" | ||
17 | |||
18 | SRC_URI = "http://fallabs.com/tokyocabinet/${BP}.tar.gz \ | ||
19 | file://remove-hard-coded-include-and-lib-paths.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "fd03df6965f8f56dd5b8518ca43b4f5e" | ||
23 | SRC_URI[sha256sum] = "a003f47c39a91e22d76bc4fe68b9b3de0f38851b160bbb1ca07a4f6441de1f90" | ||
24 | |||
25 | DEPENDS = "bzip2 zlib" | ||
26 | |||
27 | inherit autotools-brokensep | ||