diff options
Diffstat (limited to 'meta-oe/recipes-support/tbb/tbb_2021.7.0.bb')
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb_2021.7.0.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb_2021.7.0.bb b/meta-oe/recipes-support/tbb/tbb_2021.7.0.bb new file mode 100644 index 000000000..8c72b349d --- /dev/null +++ b/meta-oe/recipes-support/tbb/tbb_2021.7.0.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ | ||
2 | TBB is a library that helps you leverage multi-core processor \ | ||
3 | performance without having to be a threading expert. It represents a \ | ||
4 | higher-level, task-based parallelism that abstracts platform details \ | ||
5 | and threading mechanism for performance and scalability." | ||
6 | HOMEPAGE = "https://software.intel.com/en-us/tbb" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327" | ||
9 | |||
10 | DEPENDS:append:libc-musl = " libucontext" | ||
11 | |||
12 | PE = "1" | ||
13 | |||
14 | BRANCH = "onetbb_2021" | ||
15 | SRCREV = "7673da272f7e1592876b42cfe98b9f4cadf6ae41" | ||
16 | SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \ | ||
17 | file://0001-CMakeLists.txt-exclude-riscv64-riscv32.patch \ | ||
18 | " | ||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | inherit cmake | ||
22 | |||
23 | # test build fails, error: 'mallinfo mallinfo()' is deprecated | ||
24 | EXTRA_OECMAKE += " \ | ||
25 | -DTBB_TEST=OFF \ | ||
26 | -DCMAKE_BUILD_TYPE=Release \ | ||
27 | " | ||
28 | # Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi) | ||
29 | # tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: /tmp/lto-llvm-264bc2.o: can't link soft-float modules with double-float modules | ||
30 | # tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: failed to merge target specific data of file /tmp/lto-llvm-264bc2.o | ||
31 | EXTRA_OECMAKE:append:riscv32:toolchain-clang = " -DTBB_ENABLE_IPO=OFF " | ||
32 | EXTRA_OECMAKE:append:riscv64:toolchain-clang = " -DTBB_ENABLE_IPO=OFF " | ||
33 | |||
34 | # fails with thumb enabled: | ||
35 | # | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp | ||
36 | # | {standard input}: Assembler messages: | ||
37 | # | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]' | ||
38 | # ... | ||
39 | # | make[1]: *** [concurrent_queue.o] Error 1 | ||
40 | ARM_INSTRUCTION_SET = "arm" | ||
41 | |||
42 | ASNEEDED = "" | ||
43 | |||
44 | LDFLAGS:append:mips = " -latomic" | ||
45 | LDFLAGS:append:mipsel = " -latomic" | ||
46 | LDFLAGS:append:riscv32:toolchain-clang = " -latomic" | ||
47 | |||
48 | LDFLAGS:append:libc-musl = " -lucontext" | ||
49 | |||
50 | # The latest version of oneTBB does not support PPC | ||
51 | COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*" | ||
52 | |||
53 | BBCLASSEXTEND = "native nativesdk" | ||