summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb')
-rw-r--r--meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb
new file mode 100644
index 000000000..d2199c2cf
--- /dev/null
+++ b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb
@@ -0,0 +1,29 @@
1SUMMARY = "xorg.conf keyboard layout callout"
2DESCRIPTION = "system-setup-keyboard is a daemon to monitor the keyboard layout configured in \
3/etc/sysconfig/keyboard and transfer this into the matching xorg.conf.d snippet."
4
5HOMEPAGE = "https://git.fedorahosted.org/git/system-setup-keyboard.git"
6SECTION = "Applications/System"
7
8SRC_URI = "https://git.fedorahosted.org/cgit/${PN}.git/snapshot/${BP}.tar.gz"
9SRC_URI[md5sum] = "399003968ccc739cddd9cc370af377a0"
10SRC_URI[sha256sum] = "1ef6ef79c3588e85d7f42e99eb80a2e459f966284cf029c2d6fc1b645abcb860"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://COPYING;md5=bf57969a59612c5aca007b340c49d3a2"
14
15inherit pythonnative
16
17DEPENDS = "glib-2.0 system-config-keyboard-native"
18
19do_compile_prepend() {
20 ${PYTHON} -v get_layouts.py > keyboards.h
21}
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25 install -d ${D}/etc/X11/xorg.conf.d
26 touch ${D}/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
27}
28
29FILES_${PN} += "${systemd_unitdir}/system/${PN}.service"