summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/sqlite/sqlite-2.8.17
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/sqlite/sqlite-2.8.17')
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch32
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch20
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc12
3 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
new file mode 100644
index 000000000..914422f1d
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
@@ -0,0 +1,32 @@
1diff -urN sqlite-2.8.17.orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17.orig/main.mk 2005-04-23 22:43:23.000000000 +0000
3+++ sqlite-2.8.17/main.mk 2009-04-02 20:10:36.000000000 +0000
4@@ -139,7 +139,7 @@
5 # This is the default Makefile target. The objects listed here
6 # are what get build when you type just "make" with no arguments.
7 #
8-all: sqlite.h config.h libsqlite.a sqlite$(EXE)
9+all: sqlite.h config.h libsqlite.so sqlite$(EXE)
10
11 # Generate the file "last_change" which contains the date of change
12 # of the most recently modified source code file
13@@ -148,13 +148,12 @@
14 cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
15 | awk '{print $$5,$$6}' >last_change
16
17-libsqlite.a: $(LIBOBJ)
18- $(AR) libsqlite.a $(LIBOBJ)
19- $(RANLIB) libsqlite.a
20-
21-sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
22- $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
23- libsqlite.a $(LIBREADLINE) $(THREADLIB)
24+libsqlite.so: $(LIBOBJ)
25+ $(CC) $(LDFLAGS) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
26+
27+sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
28+ $(TCCX) $(LDFLAGS) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
29+ -lsqlite $(LIBREADLINE) $(THREADLIB)
30
31 sqlite_analyzer$(EXE): $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
32 $(TOP)/tool/spaceanal.tcl
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
new file mode 100644
index 000000000..b84b6486e
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
@@ -0,0 +1,20 @@
1diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17~orig/main.mk 2006-02-13 04:09:33.000000000 -0600
3+++ sqlite-2.8.17/main.mk 2006-02-13 04:15:42.000000000 -0600
4@@ -58,7 +58,7 @@
5 expr.o func.o hash.o insert.o \
6 main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o \
7 select.o table.o tokenize.o trigger.o update.o util.o \
8- vacuum.o vdbe.o vdbeaux.o where.o tclsqlite.o
9+ vacuum.o vdbe.o vdbeaux.o where.o
10
11 # All of the source code files.
12 #
13@@ -91,7 +91,6 @@
14 $(TOP)/src/sqlite.h.in \
15 $(TOP)/src/sqliteInt.h \
16 $(TOP)/src/table.c \
17- $(TOP)/src/tclsqlite.c \
18 $(TOP)/src/tokenize.c \
19 $(TOP)/src/trigger.c \
20 $(TOP)/src/update.c \
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
new file mode 100644
index 000000000..6bc742eec
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
@@ -0,0 +1,12 @@
1# Package Information for pkg-config
2
3prefix=/usr
4exec_prefix=${prefix}
5libdir=${exec_prefix}/lib
6includedir=${prefix}/include
7
8Name: SQLite
9Description: SQL database engine
10Version: 2.8.17
11Libs: -L${libdir} -lsqlite
12Cflags: -I${includedir}