summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb')
-rw-r--r--meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb b/meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb
new file mode 100644
index 000000000..30c41fffb
--- /dev/null
+++ b/meta-oe/recipes-support/pxaregs/pxaregs_1.14.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Tool to display and modify PXA registers at runtime"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://pxaregs.c;endline=12;md5=668d061b7637acc68cb8071c9be372e6"
4AUTHOR = "Holger Schurig <hs4233@mail.mn-solutions.de>"
5HOMEPAGE = "http://www.mn-logistik.de/unsupported/pxa250/"
6
7SRC_URI = "file://pxaregs.c \
8 file://i2c.patch \
9 file://munmap.patch \
10 file://serial.patch \
11 file://usb.patch "
12
13S = "${WORKDIR}"
14
15do_compile() {
16 ${CC} pxaregs.c -o pxaregs ${CFLAGS} ${LDFLAGS}
17}
18
19do_install() {
20 install -d ${D}${sbindir}/
21 install -m 0755 pxaregs ${D}${sbindir}/
22}
23
24SRC_URI[md5sum] = "a43baa88842cd5926dbffb6fb87624f6"
25SRC_URI[sha256sum] = "f339b91cd8ab348052c36b36d20033e4bffc3666bc836ff72d5704f025e1c057"