diff options
Diffstat (limited to 'meta-oe/recipes-support/postgresql')
4 files changed, 104 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/files/no-ecpg-test.patch b/meta-oe/recipes-support/postgresql/files/no-ecpg-test.patch new file mode 100644 index 000000000..c0f28f425 --- /dev/null +++ b/meta-oe/recipes-support/postgresql/files/no-ecpg-test.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | diff --git a/src/interfaces/ecpg/Makefile b/src/interfaces/ecpg/Makefile | ||
2 | index dcd578f..1428423 100644 | ||
3 | --- a/src/interfaces/ecpg/Makefile | ||
4 | +++ b/src/interfaces/ecpg/Makefile | ||
5 | @@ -8,7 +8,6 @@ all install installdirs uninstall dep depend distprep: | ||
6 | $(MAKE) -C ecpglib $@ | ||
7 | $(MAKE) -C compatlib $@ | ||
8 | $(MAKE) -C preproc $@ | ||
9 | - $(MAKE) -C test $@ | ||
10 | |||
11 | clean distclean maintainer-clean: | ||
12 | -$(MAKE) -C include $@ | ||
diff --git a/meta-oe/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch b/meta-oe/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch new file mode 100644 index 000000000..d027061d8 --- /dev/null +++ b/meta-oe/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: postgresql-8.4.4/configure.in | ||
2 | =================================================================== | ||
3 | --- postgresql-8.4.4.orig/configure.in | ||
4 | +++ postgresql-8.4.4/configure.in | ||
5 | @@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch un | ||
6 | |||
7 | AC_INIT([PostgreSQL], [8.4.4], [pgsql-bugs@postgresql.org]) | ||
8 | |||
9 | -m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required. | ||
10 | -Untested combinations of 'autoconf' and PostgreSQL versions are not | ||
11 | -recommended. You can remove the check from 'configure.in' but it is then | ||
12 | -your responsibility whether the result works or not.])]) | ||
13 | AC_COPYRIGHT([Copyright (c) 1996-2009, PostgreSQL Global Development Group]) | ||
14 | AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c]) | ||
15 | AC_CONFIG_AUX_DIR(config) | ||
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc new file mode 100644 index 000000000..edad3bcc5 --- /dev/null +++ b/meta-oe/recipes-support/postgresql/postgresql.inc | |||
@@ -0,0 +1,66 @@ | |||
1 | DESCRIPTION = "PostgreSQL is a powerful, open source relational database system." | ||
2 | HOMEPAGE = "http://www.postgresql.com" | ||
3 | LICENSE = "BSD" | ||
4 | |||
5 | DEPENDS = "zlib readline tzcode-native" | ||
6 | |||
7 | ARM_INSTRUCTION_SET = "arm" | ||
8 | |||
9 | #WARNING: this recipe assumes you have the timezone compiler present in /usr/sbin/zic | ||
10 | |||
11 | SRC_URI = "ftp://ftp-archives.postgresql.org/pub/source/v${PV}/${P}.tar.bz2" | ||
12 | |||
13 | LEAD_SONAME = "libpq.so" | ||
14 | |||
15 | # LDFLAGS for shared libraries | ||
16 | export LDFLAGS_SL = "${LDFLAGS}" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | do_compile_append() { | ||
21 | cp /usr/sbin/zic ${S}/src/timezone/ | ||
22 | } | ||
23 | |||
24 | PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \ | ||
25 | libecpg-compat-dbg libecpg-compat \ | ||
26 | libecpg-dbg libecpg libecpg-dev \ | ||
27 | libpq-dbg libpq libpq-dev \ | ||
28 | libpgtypes-dbg libpgtypes " | ||
29 | |||
30 | FILES_${PN}-client = "${bindir}/clusterdb \ | ||
31 | ${bindir}/createdb \ | ||
32 | ${bindir}/createlang \ | ||
33 | ${bindir}/createuser \ | ||
34 | ${bindir}/dropdb \ | ||
35 | ${bindir}/droplang \ | ||
36 | ${bindir}/dropuser \ | ||
37 | ${bindir}/pg_dump \ | ||
38 | ${bindir}/pg_dumpall \ | ||
39 | ${bindir}/pg_restore \ | ||
40 | ${bindir}/psql \ | ||
41 | ${bindir}/reindexdb \ | ||
42 | ${bindir}/vacuumdb \ | ||
43 | ${bindir}/vacuumlo \ | ||
44 | ${datadir}/${PN}/psqlrc.sample" | ||
45 | |||
46 | FILES_${PN}-doc += "${prefix}/doc/" | ||
47 | FILES_${PN}-timezone = "${datadir}/${PN}/timezone" | ||
48 | FILES_${PN}-server-dev = "${includedir}/${PN}/server" | ||
49 | |||
50 | FILES_libecpg = "${libdir}/libecpg*.so.*" | ||
51 | FILES_libecpg-dbg = "${libdir}/.debug/libecpg*" | ||
52 | FILES_libecpg-dev = "${libdir}/libecpg*.a ${libdir}/libecpg*.so \ | ||
53 | ${libdir}/libpgtypes*.a ${libdir}/libpgtypes*.so \ | ||
54 | ${includedir}/ecpg*.h ${includedir}/${PN}/ecpg*.h \ | ||
55 | ${includedir}/pgtypes*.h ${includedir}/${PN}/informix \ | ||
56 | ${includedir}/sql3types.h ${includedir}/sqlca.h" | ||
57 | |||
58 | FILES_libpq = "${libdir}/libpq*.so.*" | ||
59 | FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${PN}/pgxs/src/test/regress/.debug/*" | ||
60 | FILES_libpq-dev = "${libdir}/libpq*.a ${libdir}/libpq*.so ${libdir}/libpgport.a \ | ||
61 | ${includedir}" | ||
62 | |||
63 | FILES_libecpg-compat = "${libdir}/libecpg_compat*.so.*" | ||
64 | FILES_libecpg-compat-dbg = "${libdir}/.debug/libecpg_compat*" | ||
65 | FILES_libpgtypes = "${libdir}/libpgtypes*.so.*" | ||
66 | FILES_libpgtypes-dbg = "${libdir}/.debug/libpgtypes*" | ||
diff --git a/meta-oe/recipes-support/postgresql/postgresql_8.4.4.bb b/meta-oe/recipes-support/postgresql/postgresql_8.4.4.bb new file mode 100644 index 000000000..d0f507849 --- /dev/null +++ b/meta-oe/recipes-support/postgresql/postgresql_8.4.4.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require postgresql.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=29b81b066680be9ffd98cb9d2afb9de6" | ||
4 | |||
5 | DEFAULT_PREFERENCE = "-1" | ||
6 | |||
7 | SRC_URI = "ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.bz2 \ | ||
8 | file://remove.autoconf.version.check.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "4bf2448ad965bca3940df648c02194df" | ||
11 | SRC_URI[sha256sum] = "e66b398d565f7fb16d8ae58ae72881dcd3dbb1b88f532bbe1c2d1284812be37e" | ||