summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch')
-rw-r--r--meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch b/meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch
new file mode 100644
index 000000000..3cffc0a85
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/files/0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch
@@ -0,0 +1,75 @@
1From 0ae841a98c21c53901d5bc9a9323a8cc800364f6 Mon Sep 17 00:00:00 2001
2From: Noah Misch <noah@leadboat.com>
3Date: Sat, 14 Jun 2014 10:52:25 -0400
4Subject: [PATCH] Make pqsignal() available to pg_regress of ECPG and
5 isolation suites.
6
7commit 0ae841a98c21c53901d5bc9a9323a8cc800364f6 REL9_2_STABLE
8
9Commit 453a5d91d49e4d35054f92785d830df4067e10c1 made it available to the
10src/test/regress build of pg_regress, but all pg_regress builds need the
11same treatment. Patch 9.2 through 8.4; in 9.3 and later, pg_regress
12gets pqsignal() via libpgport.
13
14
15Upstream-Status: Backport
16
17Signed-off-by: Kai Kang <kai.kang@windriver.com>
18---
19 src/interfaces/ecpg/test/Makefile | 4 ++--
20 src/test/isolation/Makefile | 12 +++++++-----
21 2 files changed, 9 insertions(+), 7 deletions(-)
22
23diff --git a/src/interfaces/ecpg/test/Makefile b/src/interfaces/ecpg/test/Makefile
24index e9944c6..4bb9525 100644
25--- a/src/interfaces/ecpg/test/Makefile
26+++ b/src/interfaces/ecpg/test/Makefile
27@@ -47,10 +47,10 @@ clean distclean maintainer-clean:
28
29 all: pg_regress$(X)
30
31-pg_regress$(X): pg_regress_ecpg.o $(top_builddir)/src/test/regress/pg_regress.o
32+pg_regress$(X): pg_regress_ecpg.o $(top_builddir)/src/test/regress/pg_regress.o $(top_builddir)/src/test/regress/pqsignal.o
33 $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $^ $(LIBS) -o $@
34
35-$(top_builddir)/src/test/regress/pg_regress.o:
36+$(top_builddir)/src/test/regress/pg_regress.o $(top_builddir)/src/test/regress/pqsignal.o:
37 $(MAKE) -C $(dir $@) $(notdir $@)
38
39 # dependencies ensure that path changes propagate
40diff --git a/src/test/isolation/Makefile b/src/test/isolation/Makefile
41index 46ea6f0..e20ba48 100644
42--- a/src/test/isolation/Makefile
43+++ b/src/test/isolation/Makefile
44@@ -15,13 +15,15 @@ OBJS = specparse.o isolationtester.o
45
46 all: isolationtester$(X) pg_isolation_regress$(X)
47
48-submake-regress:
49+pg_regress.o:
50 $(MAKE) -C $(top_builddir)/src/test/regress pg_regress.o
51-
52-pg_regress.o: | submake-regress
53 rm -f $@ && $(LN_S) $(top_builddir)/src/test/regress/pg_regress.o .
54
55-pg_isolation_regress$(X): isolation_main.o pg_regress.o
56+pqsignal.o:
57+ $(MAKE) -C $(top_builddir)/src/test/regress pqsignal.o
58+ rm -f $@ && $(LN_S) $(top_builddir)/src/test/regress/pqsignal.o .
59+
60+pg_isolation_regress$(X): isolation_main.o pg_regress.o pqsignal.o
61 $(CC) $(CFLAGS) $^ $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
62
63 isolationtester$(X): $(OBJS) | submake-libpq submake-libpgport
64@@ -59,7 +61,7 @@ endif
65 # so do not clean them here
66 clean distclean:
67 rm -f isolationtester$(X) pg_isolation_regress$(X) $(OBJS) isolation_main.o
68- rm -f pg_regress.o
69+ rm -f pg_regress.o pqsignal.o
70 rm -rf $(pg_regress_clean_files)
71
72 maintainer-clean: distclean
73--
741.7.5.4
75