diff options
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler_0.50.0.bb')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.50.0.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_0.50.0.bb b/meta-oe/recipes-support/poppler/poppler_0.50.0.bb new file mode 100644 index 000000000..56425e635 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler_0.50.0.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
4 | |||
5 | SRC_URI = " \ | ||
6 | http://poppler.freedesktop.org/${BP}.tar.xz \ | ||
7 | file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \ | ||
8 | file://0002-fix-gcc-6-math-ambiguous-errors.patch \ | ||
9 | " | ||
10 | SRC_URI[md5sum] = "1a4c0cd873bddd8f266b85ab8d799962" | ||
11 | SRC_URI[sha256sum] = "c9c93318b789d3933f6e0bad3bc65110280c28eac3f0666284bb9c9a0ab4bc36" | ||
12 | |||
13 | DEPENDS = "fontconfig zlib cairo lcms" | ||
14 | |||
15 | inherit autotools pkgconfig gtk-doc gobject-introspection | ||
16 | |||
17 | PACKAGECONFIG ??= "jpeg openjpeg png tiff nss ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}" | ||
18 | PACKAGECONFIG[jpeg] = "--enable-libjpeg,--disable-libjpeg,jpeg" | ||
19 | PACKAGECONFIG[png] = "--enable-libpng,--disable-libpng,libpng" | ||
20 | PACKAGECONFIG[tiff] = "--enable-libtiff,--disable-libtiff,tiff" | ||
21 | PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl" | ||
22 | PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg" | ||
23 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" | ||
24 | PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded" | ||
25 | PACKAGECONFIG[nss] = "--enable-libnss,--disable-libnss,nss" | ||
26 | |||
27 | # Needed for qt5 | ||
28 | CXXFLAGS += "--std=c++11" | ||
29 | |||
30 | #| /usr/src/debug/glibc/2.25-r0/git/csu/elf-init.c:87: undefined reference to `__init_array_end' | ||
31 | #| /usr/src/debug/glibc/2.25-r0/git/csu/elf-init.c:87: undefined reference to `__init_array_start' | ||
32 | #| /mnt/a/build/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/6.2.0/ld: .libs/libpoppler.so.65.0.0: hidden symbol `__init_array_end' isn't defined | ||
33 | |||
34 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" | ||
35 | |||
36 | EXTRA_OECONF = "\ | ||
37 | --enable-xpdf-headers \ | ||
38 | --disable-gtk-test \ | ||
39 | --enable-zlib \ | ||
40 | " | ||
41 | |||
42 | do_compile_prepend() { | ||
43 | export GIR_EXTRA_LIBS_PATH="${B}/poppler/.libs" | ||
44 | } | ||
45 | |||
46 | # Adjust library names when building for QT4e | ||
47 | QT4E_PATCHES = "${@bb.utils.contains('PACKAGECONFIG', 'qt4e', 'file://fix-qt4e-library-dependencies.patch', '', d)}" | ||
48 | SRC_URI_append = "${QT4E_PATCHES}" | ||
49 | |||
50 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | ||
51 | def get_poppler_fpu_setting(bb, d): | ||
52 | if d.getVar('TARGET_FPU') in [ 'soft' ]: | ||
53 | return "--enable-fixedpoint" | ||
54 | return "" | ||
55 | |||
56 | EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}" | ||
57 | |||
58 | PACKAGES =+ "libpoppler libpoppler-glib" | ||
59 | FILES_libpoppler = "${libdir}/libpoppler.so.*" | ||
60 | FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*" | ||
61 | |||
62 | RDEPENDS_libpoppler = "poppler-data" | ||