summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poco/poco_1.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/poco/poco_1.12.4.bb')
-rw-r--r--meta-oe/recipes-support/poco/poco_1.12.4.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poco/poco_1.12.4.bb b/meta-oe/recipes-support/poco/poco_1.12.4.bb
index 47dac1a89..b02b84fa6 100644
--- a/meta-oe/recipes-support/poco/poco_1.12.4.bb
+++ b/meta-oe/recipes-support/poco/poco_1.12.4.bb
@@ -10,6 +10,7 @@ DEPENDS = "libpcre2 zlib"
10 10
11SRC_URI = "git://github.com/pocoproject/poco.git;branch=master;protocol=https \ 11SRC_URI = "git://github.com/pocoproject/poco.git;branch=master;protocol=https \
12 file://0001-Use-std-atomic-int-instead-of-std-atomic-bool.patch \ 12 file://0001-Use-std-atomic-int-instead-of-std-atomic-bool.patch \
13 file://0001-cppignore.lnx-Ignore-PKCS12-and-testLaunch-test.patch \
13 file://run-ptest \ 14 file://run-ptest \
14 " 15 "
15SRCREV = "1211613642269b7d53bea58b02de7fcd25ece3b9" 16SRCREV = "1211613642269b7d53bea58b02de7fcd25ece3b9"
@@ -24,6 +25,11 @@ inherit cmake ptest
24# Foundation is built anyway and doesn't need to be listed explicitly 25# Foundation is built anyway and doesn't need to be listed explicitly
25# these don't have dependencies outside oe-core 26# these don't have dependencies outside oe-core
26PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto JWT Data DataSQLite Zip Encodings Redis Prometheus" 27PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto JWT Data DataSQLite Zip Encodings Redis Prometheus"
28# MongoDB does not build for all architectures yet keep in sync with COMPATIBLE_HOST list in mongodb recipe
29PACKAGECONFIG:remove:riscv32 = "MongoDB"
30PACKAGECONFIG:remove:riscv64 = "MongoDB"
31PACKAGECONFIG:remove:mipsarch = "MongoDB"
32PACKAGECONFIG:remove:powerpc = "MongoDB"
27 33
28PACKAGECONFIG[XML] = "-DENABLE_XML=ON,-DENABLE_XML=OFF,expat" 34PACKAGECONFIG[XML] = "-DENABLE_XML=ON,-DENABLE_XML=OFF,expat"
29PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF" 35PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF"
@@ -105,5 +111,7 @@ FILES:${PN}-cppunit += "${libdir}/libCppUnit.so*"
105ALLOW_EMPTY:${PN}-cppunit = "1" 111ALLOW_EMPTY:${PN}-cppunit = "1"
106 112
107RDEPENDS:${PN}-ptest += "${PN}-cppunit" 113RDEPENDS:${PN}-ptest += "${PN}-cppunit"
114RDEPENDS:${PN}-ptest += "${@bb.utils.contains('PACKAGECONFIG', 'MongoDB', 'mongodb', '', d)}"
115RDEPENDS:${PN}-ptest += "${@bb.utils.contains('PACKAGECONFIG', 'Redis', 'redis', '', d)}"
108 116
109BBCLASSEXTEND = "native" 117BBCLASSEXTEND = "native"