summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch')
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch35
1 files changed, 23 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
index 57c4c4681..cfc681cd8 100644
--- a/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
+++ b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
@@ -1,16 +1,27 @@
1Index: pidgin-2.6.5/configure.ac 1From 428836ba7f9048970626ef0d6b805107f7c52d33 Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Herrie <github.com@herrie.org>
3--- pidgin-2.6.5.orig/configure.ac 3Date: Thu, 5 May 2016 13:33:29 +0200
4+++ pidgin-2.6.5/configure.ac 4Subject: [PATCH] Updated python patch
5@@ -1470,8 +1470,9 @@ if test "_$pythonpath" != _ ; then 5
6 AC_CHECK_LIB(pthread, pthread_create, ) 6---
7 AC_CHECK_LIB(util, openpty, ) 7 configure.ac | 6 +++---
8 AC_CHECK_LIB(db, dbopen, ) 8 1 file changed, 3 insertions(+), 3 deletions(-)
9- PY_LIBS="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config -lpython$PY_VERSION" 9
10- PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION" 10diff --git a/configure.ac b/configure.ac
11index 94ea8cf..2285adb 100644
12--- a/configure.ac
13+++ b/configure.ac
14@@ -1587,9 +1587,9 @@ dnl (Thanks to XChat)
15 if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then
16 AC_MSG_CHECKING(for Python compile flags)
17 if test -f ${PYTHON}-config; then
18- PY_CFLAGS=`${PYTHON}-config --includes`
19- PY_LIBS=`${PYTHON}-config --libs`
20- AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
11+ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$]) 21+ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
12+ PY_LIBS="-L$PKG_CONFIG_SYSROOT_DIR/usr/lib/python$PY_VERSION/config -lpython$PY_VERSION" 22+ PY_LIBS="-L$PKG_CONFIG_SYSROOT_DIR/usr/lib/python$PY_VERSION/config -lpython$PY_VERSION"
13+ PY_CFLAGS="-I$PKG_CONFIG_SYSROOT_DIR/usr/include/python$PY_VERSION" 23+ PY_CFLAGS="-I$PKG_CONFIG_SYSROOT_DIR/usr/include/python$PY_VERSION" AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
14 AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
15 AC_MSG_RESULT(ok) 24 AC_MSG_RESULT(ok)
16 else 25 else
26 AC_MSG_RESULT([Cannot find ${PYTHON}-config])
27