summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb')
-rw-r--r--meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb
new file mode 100644
index 000000000..1d86f1abc
--- /dev/null
+++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.16.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Open Telemetry Library"
2DESCRIPTION = "An Observability framework to create and manage telemetry data \
3such as traces, metrics, and logs."
4HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
5SECTION = "libs"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9DEPENDS = "nlohmann-json"
10
11SRC_URI = "git://github.com/open-telemetry/opentelemetry-cpp.git;protocol=https;branch=main \
12 file://0001-Fix-build-with-clang-19.patch"
13SRCREV = "baecbb95bd63df53e0af16e87bc683967962c5f8"
14
15S = "${WORKDIR}/git"
16inherit cmake pkgconfig lib_package
17
18LDFLAGS:append:riscv32 = " -latomic"
19
20PACKAGECONFIG ?= "opentelemety_install otlp_api"
21
22PACKAGECONFIG[opentelemety_install]="-DOPENTELEMETRY_INSTALL=ON,-DOPENTELEMETRY_INSTALL=OFF"
23PACKAGECONFIG[build_package]="-DBUILD_PACKAGE=ON,-DBUILD_PACKAGE=OFF"
24PACKAGECONFIG[otlp_api]="-DWITH_OTLP_API=ON,-DWITH_OTLP_API=OFF"
25PACKAGECONFIG[otlp_grpc]="-DWITH_OTLP_GRPC=ON,-DWITH_OTLP_GRPC=OFF"
26PACKAGECONFIG[otlp_http]="-DWITH_OTLP_HTTP=ON,-DWITH_OTLP_HTTP=OFF"
27PACKAGECONFIG[otlp_prometheus]="-DWITH_PROMETHEUS=ON,-DWITH_PROMETHEUS=OFF"
28PACKAGECONFIG[benchmark]="-DWITH_BENCHMARK=ON,-DWITH_BENCHMARK=OFF"
29PACKAGECONFIG[testing]="-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF"