summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openldap
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/openldap')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.23.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
index 8d9bd6c6b..b9441efc5 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
@@ -11,7 +11,7 @@ LICENSE = "OpenLDAP"
11LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3d82d3085f228af211a6502c7ea7c3c7" 11LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3d82d3085f228af211a6502c7ea7c3c7"
12SECTION = "libs" 12SECTION = "libs"
13 13
14LDAP_VER = "${@'.'.join(bb.data.getVar('PV',d,1).split('.')[0:2])}" 14LDAP_VER = "${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
15 15
16SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz" 16SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz"
17SRC_URI += "file://openldap-m4-pthread.patch" 17SRC_URI += "file://openldap-m4-pthread.patch"
@@ -252,19 +252,19 @@ pkg_prerm_${PN}-slapd () {
252PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*" 252PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*"
253 253
254python populate_packages_prepend () { 254python populate_packages_prepend () {
255 backend_dir = bb.data.expand('${libexecdir}/openldap', d) 255 backend_dir = d.expand('${libexecdir}/openldap')
256 do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True) 256 do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True)
257 257
258 metapkg = "openldap-backends" 258 metapkg = "openldap-backends"
259 bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) 259 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
260 bb.data.setVar('FILES_' + metapkg, "", d) 260 d.setVar('FILES_' + metapkg, "")
261 metapkg_rdepends = [] 261 metapkg_rdepends = []
262 packages = bb.data.getVar('PACKAGES', d, 1).split() 262 packages = d.getVar('PACKAGES', 1).split()
263 for pkg in packages[1:]: 263 for pkg in packages[1:]:
264 if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"): 264 if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"):
265 metapkg_rdepends.append(pkg) 265 metapkg_rdepends.append(pkg)
266 bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) 266 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
267 bb.data.setVar('DESCRIPTION_' + metapkg, 'OpenLDAP backends meta package', d) 267 d.setVar('DESCRIPTION_' + metapkg, 'OpenLDAP backends meta package')
268 packages.append(metapkg) 268 packages.append(metapkg)
269 bb.data.setVar('PACKAGES', ' '.join(packages), d) 269 d.setVar('PACKAGES', ' '.join(packages))
270} 270}