diff options
Diffstat (limited to 'meta-oe/recipes-support/openldap/openldap_2.4.44.bb')
-rw-r--r-- | meta-oe/recipes-support/openldap/openldap_2.4.44.bb | 254 |
1 files changed, 254 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb new file mode 100644 index 0000000000..48e9066f9f --- /dev/null +++ b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb | |||
@@ -0,0 +1,254 @@ | |||
1 | # OpenLDAP, a license free (see http://www.OpenLDAP.org/license.html) | ||
2 | # | ||
3 | SUMMARY = "OpenLDAP Directory Service" | ||
4 | DESCRIPTION = "OpenLDAP Software is an open source implementation of the Lightweight Directory Access Protocol." | ||
5 | HOMEPAGE = "http://www.OpenLDAP.org/license.html" | ||
6 | # The OpenLDAP Public License - see the HOMEPAGE - defines | ||
7 | # the license. www.openldap.org claims this is Open Source | ||
8 | # (see http://www.openldap.org), the license appears to be | ||
9 | # basically BSD. opensource.org does not record this license | ||
10 | # at present (so it is apparently not OSI certified). | ||
11 | LICENSE = "OpenLDAP" | ||
12 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c933fba6d89fda89f58df1e086e3f2e7 \ | ||
13 | file://LICENSE;md5=153d07ef052c4a37a8fac23bc6031972 \ | ||
14 | " | ||
15 | SECTION = "libs" | ||
16 | |||
17 | LDAP_VER = "${@'.'.join(d.getVar('PV',1).split('.')[0:2])}" | ||
18 | |||
19 | SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${BP}.tgz \ | ||
20 | file://openldap-m4-pthread.patch \ | ||
21 | file://kill-icu.patch \ | ||
22 | file://openldap-2.4.28-gnutls-gcrypt.patch \ | ||
23 | file://use-urandom.patch \ | ||
24 | file://initscript \ | ||
25 | file://slapd.service \ | ||
26 | file://thread_stub.patch \ | ||
27 | " | ||
28 | |||
29 | SRC_URI[md5sum] = "693ac26de86231f8dcae2b4e9d768e51" | ||
30 | SRC_URI[sha256sum] = "d7de6bf3c67009c95525dde3a0212cc110d0a70b92af2af8e3ee800e81b88400" | ||
31 | |||
32 | DEPENDS = "util-linux groff-native" | ||
33 | |||
34 | # The original top.mk used INSTALL, not INSTALL_STRIP_PROGRAM when | ||
35 | # installing .so and executables, this fails in cross compilation | ||
36 | # environments | ||
37 | SRC_URI += "file://install-strip.patch" | ||
38 | |||
39 | inherit autotools-brokensep update-rc.d systemd | ||
40 | |||
41 | # CV SETTINGS | ||
42 | # Required to work round AC_FUNC_MEMCMP which gets the wrong answer | ||
43 | # when cross compiling (should be in site?) | ||
44 | EXTRA_OECONF += "ac_cv_func_memcmp_working=yes" | ||
45 | |||
46 | # CONFIG DEFINITIONS | ||
47 | # The following is necessary because it cannot be determined for a | ||
48 | # cross compile automagically. Select should yield fine on all OE | ||
49 | # systems... | ||
50 | EXTRA_OECONF += "--with-yielding-select=yes" | ||
51 | # Shared libraries are nice... | ||
52 | EXTRA_OECONF += "--enable-dynamic" | ||
53 | |||
54 | PACKAGECONFIG ??= "gnutls modules \ | ||
55 | ldap meta monitor null passwd shell proxycache dnssrv \ | ||
56 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ | ||
57 | " | ||
58 | #--with-tls with TLS/SSL support auto|openssl|gnutls [auto] | ||
59 | PACKAGECONFIG[gnutls] = "--with-tls=gnutls,,gnutls libgcrypt" | ||
60 | PACKAGECONFIG[openssl] = "--with-tls=openssl,,openssl" | ||
61 | |||
62 | PACKAGECONFIG[sasl] = "--with-cyrus-sasl,--without-cyrus-sasl,cyrus-sasl" | ||
63 | PACKAGECONFIG[modules] = "lt_cv_dlopen_self=yes --enable-modules,--disable-modules,libtool" | ||
64 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6" | ||
65 | |||
66 | # SLAPD options | ||
67 | # | ||
68 | # UNIX crypt(3) passwd support: | ||
69 | EXTRA_OECONF += "--enable-crypt" | ||
70 | |||
71 | # SLAPD BACKEND | ||
72 | # | ||
73 | # The backend must be set by the configuration. This controls the | ||
74 | # required database. | ||
75 | # | ||
76 | # Backends="bdb dnssrv hdb ldap mdb meta monitor ndb null passwd perl relay shell sock sql" | ||
77 | # | ||
78 | # Note that multiple backends can be built. The ldbm backend requires a | ||
79 | # build-time choice of database API. The bdb backend forces this to be | ||
80 | # DB4. To use the gdbm (or other) API the Berkely database module must | ||
81 | # be removed from the build. | ||
82 | md = "${libexecdir}/openldap" | ||
83 | # | ||
84 | #--enable-bdb enable Berkeley DB backend no|yes|mod yes | ||
85 | # The Berkely DB is the standard choice. This version of OpenLDAP requires | ||
86 | # the version 4 implementation or better. | ||
87 | PACKAGECONFIG[bdb] = "--enable-bdb=yes,--enable-bdb=no,db" | ||
88 | |||
89 | #--enable-dnssrv enable dnssrv backend no|yes|mod no | ||
90 | PACKAGECONFIG[dnssrv] = "--enable-dnssrv=mod,--enable-dnssrv=no" | ||
91 | |||
92 | #--enable-hdb enable Hierarchical DB backend no|yes|mod no | ||
93 | PACKAGECONFIG[hdb] = "--enable-hdb=yes,--enable-hdb=no,db" | ||
94 | |||
95 | #--enable-ldap enable ldap backend no|yes|mod no | ||
96 | PACKAGECONFIG[ldap] = "--enable-ldap=mod,--enable-ldap=no," | ||
97 | |||
98 | #--enable-mdb enable mdb database backend no|yes|mod [yes] | ||
99 | PACKAGECONFIG[mdb] = "--enable-mdb=mod,--enable-mdb=no," | ||
100 | |||
101 | #--enable-meta enable metadirectory backend no|yes|mod no | ||
102 | PACKAGECONFIG[meta] = "--enable-meta=mod,--enable-meta=no," | ||
103 | |||
104 | #--enable-monitor enable monitor backend no|yes|mod yes | ||
105 | PACKAGECONFIG[monitor] = "--enable-monitor=mod,--enable-monitor=no," | ||
106 | |||
107 | #--enable-ndb enable MySQL NDB Cluster backend no|yes|mod [no] | ||
108 | PACKAGECONFIG[ndb] = "--enable-ndb=mod,--enable-ndb=no," | ||
109 | |||
110 | #--enable-null enable null backend no|yes|mod no | ||
111 | PACKAGECONFIG[null] = "--enable-null=mod,--enable-null=no," | ||
112 | |||
113 | #--enable-passwd enable passwd backend no|yes|mod no | ||
114 | PACKAGECONFIG[passwd] = "--enable-passwd=mod,--enable-passwd=no," | ||
115 | |||
116 | #--enable-perl enable perl backend no|yes|mod no | ||
117 | # This requires a loadable perl dynamic library, if enabled without | ||
118 | # doing something appropriate (building perl?) the build will pick | ||
119 | # up the build machine perl - not good (inherit perlnative?) | ||
120 | PACKAGECONFIG[perl] = "--enable-perl=mod,--enable-perl=no,perl" | ||
121 | |||
122 | #--enable-relay enable relay backend no|yes|mod [yes] | ||
123 | PACKAGECONFIG[relay] = "--enable-relay=mod,--enable-relay=no," | ||
124 | |||
125 | #--enable-shell enable shell backend no|yes|mod no | ||
126 | # configure: WARNING: Use of --without-threads is recommended with back-shell | ||
127 | PACKAGECONFIG[shell] = "--enable-shell=mod --without-threads,--enable-shell=no," | ||
128 | |||
129 | #--enable-sock enable sock backend no|yes|mod [no] | ||
130 | PACKAGECONFIG[sock] = "--enable-sock=mod,--enable-sock=no," | ||
131 | |||
132 | #--enable-sql enable sql backend no|yes|mod no | ||
133 | # sql requires some sql backend which provides sql.h, sqlite* provides | ||
134 | # sqlite.h (which may be compatible but hasn't been tried.) | ||
135 | PACKAGECONFIG[sql] = "--enable-sql=mod,--enable-sql=no,sqlite3" | ||
136 | |||
137 | #--enable-dyngroup Dynamic Group overlay no|yes|mod no | ||
138 | # This is a demo, Proxy Cache defines init_module which conflicts with the | ||
139 | # same symbol in dyngroup | ||
140 | PACKAGECONFIG[dyngroup] = "--enable-dyngroup=mod,--enable-dyngroup=no," | ||
141 | |||
142 | #--enable-proxycache Proxy Cache overlay no|yes|mod no | ||
143 | PACKAGECONFIG[proxycache] = "--enable-proxycache=mod,--enable-proxycache=no," | ||
144 | FILES_${PN}-overlay-proxycache = "${md}/pcache-*.so.*" | ||
145 | PACKAGES += "${PN}-overlay-proxycache" | ||
146 | |||
147 | # Append URANDOM_DEVICE='/dev/urandom' to CPPFLAGS: | ||
148 | # This allows tls to obtain random bits from /dev/urandom, by default | ||
149 | # it was disabled for cross-compiling. | ||
150 | CPPFLAGS_append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\'" | ||
151 | |||
152 | LDFLAGS += "-pthread" | ||
153 | |||
154 | do_configure() { | ||
155 | cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/ltmain.sh ${S}/build | ||
156 | rm -f ${S}/libtool | ||
157 | aclocal | ||
158 | libtoolize --force --copy | ||
159 | gnu-configize | ||
160 | autoconf | ||
161 | oe_runconf | ||
162 | } | ||
163 | |||
164 | LEAD_SONAME = "libldap-${LDAP_VER}.so.*" | ||
165 | |||
166 | # The executables go in a separate package. This allows the | ||
167 | # installation of the libraries with no daemon support. | ||
168 | # Each module also has its own package - see above. | ||
169 | PACKAGES += "${PN}-slapd ${PN}-slurpd ${PN}-bin" | ||
170 | |||
171 | # Package contents - shift most standard contents to -bin | ||
172 | FILES_${PN} = "${libdir}/lib*.so.* ${sysconfdir}/openldap/ldap.* ${localstatedir}/${BPN}/data" | ||
173 | FILES_${PN}-slapd = "${sysconfdir}/init.d ${libexecdir}/slapd ${sbindir} ${localstatedir}/run ${localstatedir}/volatile/run \ | ||
174 | ${sysconfdir}/openldap/slapd.* ${sysconfdir}/openldap/schema \ | ||
175 | ${sysconfdir}/openldap/DB_CONFIG.example ${systemd_unitdir}/system/*" | ||
176 | FILES_${PN}-slurpd = "${libexecdir}/slurpd ${localstatedir}/openldap-slurp ${localstatedir}/run ${localstatedir}/volatile/run" | ||
177 | FILES_${PN}-bin = "${bindir}" | ||
178 | FILES_${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libexecdir}/openldap/*.a ${libexecdir}/openldap/*.la ${libexecdir}/openldap/*.so" | ||
179 | FILES_${PN}-dbg += "${libexecdir}/openldap/.debug" | ||
180 | |||
181 | do_install_append() { | ||
182 | install -d ${D}${sysconfdir}/init.d | ||
183 | cat ${WORKDIR}/initscript > ${D}${sysconfdir}/init.d/openldap | ||
184 | chmod 755 ${D}${sysconfdir}/init.d/openldap | ||
185 | # This is duplicated in /etc/openldap and is for slapd | ||
186 | rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example | ||
187 | |||
188 | # Installing slapd under ${sbin} is more FHS and LSB compliance | ||
189 | mv ${D}${libexecdir}/slapd ${D}/${sbindir}/slapd | ||
190 | SLAPTOOLS="slapadd slapcat slapdn slapindex slappasswd slaptest slapauth slapacl slapschema" | ||
191 | cd ${D}/${sbindir}/ | ||
192 | rm -f ${SLAPTOOLS} | ||
193 | for i in ${SLAPTOOLS}; do ln -sf slapd $i; done | ||
194 | |||
195 | rmdir "${D}${localstatedir}/run" | ||
196 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | ||
197 | |||
198 | install -d ${D}${systemd_unitdir}/system/ | ||
199 | install -m 0644 ${WORKDIR}/slapd.service ${D}${systemd_unitdir}/system/ | ||
200 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/*.service | ||
201 | |||
202 | # Uses mdm as the database | ||
203 | # and localstatedir as data directory ... | ||
204 | sed -e 's/# modulepath/modulepath/' \ | ||
205 | -e 's/# moduleload\s*back_bdb.*/moduleload back_mdb/' \ | ||
206 | -e 's/database\s*bdb/database mdb/' \ | ||
207 | -e 's%^directory\s*.*%directory ${localstatedir}/${BPN}/data/%' \ | ||
208 | -i ${D}${sysconfdir}/openldap/slapd.conf | ||
209 | |||
210 | mkdir -p ${D}${localstatedir}/${BPN}/data | ||
211 | |||
212 | |||
213 | } | ||
214 | |||
215 | INITSCRIPT_PACKAGES = "${PN}-slapd" | ||
216 | INITSCRIPT_NAME_${PN}-slapd = "openldap" | ||
217 | INITSCRIPT_PARAMS_${PN}-slapd = "defaults" | ||
218 | SYSTEMD_SERVICE_${PN}-slapd = "hostapd.service" | ||
219 | SYSTEMD_AUTO_ENABLE_${PN}-slapd ?= "disable" | ||
220 | |||
221 | |||
222 | PACKAGES_DYNAMIC += "^${PN}-backends.* ^${PN}-backend-.*" | ||
223 | |||
224 | # The modules require their .so to be dynamicaly loaded | ||
225 | INSANE_SKIP_${PN}-backend-dnssrv += "dev-so" | ||
226 | INSANE_SKIP_${PN}-backend-ldap += "dev-so" | ||
227 | INSANE_SKIP_${PN}-backend-meta += "dev-so" | ||
228 | INSANE_SKIP_${PN}-backend-mdb += "dev-so" | ||
229 | INSANE_SKIP_${PN}-backend-monitor += "dev-so" | ||
230 | INSANE_SKIP_${PN}-backend-null += "dev-so" | ||
231 | INSANE_SKIP_${PN}-backend-passwd += "dev-so" | ||
232 | INSANE_SKIP_${PN}-backend-shell += "dev-so" | ||
233 | |||
234 | |||
235 | python populate_packages_prepend () { | ||
236 | backend_dir = d.expand('${libexecdir}/openldap') | ||
237 | do_split_packages(d, backend_dir, 'back_([a-z]*)\.so$', 'openldap-backend-%s', 'OpenLDAP %s backend', prepend=True, extra_depends='', allow_links=True) | ||
238 | do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True) | ||
239 | |||
240 | metapkg = "${PN}-backends" | ||
241 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") | ||
242 | d.setVar('FILES_' + metapkg, "") | ||
243 | metapkg_rdepends = [] | ||
244 | packages = d.getVar('PACKAGES', 1).split() | ||
245 | for pkg in packages[1:]: | ||
246 | if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"): | ||
247 | metapkg_rdepends.append(pkg) | ||
248 | d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends)) | ||
249 | d.setVar('DESCRIPTION_' + metapkg, 'OpenLDAP backends meta package') | ||
250 | packages.append(metapkg) | ||
251 | d.setVar('PACKAGES', ' '.join(packages)) | ||
252 | } | ||
253 | |||
254 | BBCLASSEXTEND = "native" | ||