summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openldap/openldap
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/openldap/openldap')
-rw-r--r--meta-oe/recipes-support/openldap/openldap/initscript35
-rw-r--r--meta-oe/recipes-support/openldap/openldap/install-strip.patch14
-rw-r--r--meta-oe/recipes-support/openldap/openldap/kill-icu.patch30
-rw-r--r--meta-oe/recipes-support/openldap/openldap/openldap-2.4.28-gnutls-gcrypt.patch17
-rw-r--r--meta-oe/recipes-support/openldap/openldap/openldap-m4-pthread.patch20
-rw-r--r--meta-oe/recipes-support/openldap/openldap/slapd.service10
-rw-r--r--meta-oe/recipes-support/openldap/openldap/thread_stub.patch20
-rw-r--r--meta-oe/recipes-support/openldap/openldap/use-urandom.patch38
8 files changed, 184 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap/initscript b/meta-oe/recipes-support/openldap/openldap/initscript
new file mode 100644
index 000000000..08d1067a7
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/initscript
@@ -0,0 +1,35 @@
1#! /bin/sh
2#
3# This is an init script for openembedded
4# Copy it to /etc/init.d/openldap and type
5# > update-rc.d openldap defaults 60
6#
7
8# Source function library.
9. /etc/init.d/functions
10
11slapd=/usr/sbin/slapd
12test -x "$slapd" || exit 0
13
14
15case "$1" in
16 start)
17 echo -n "Starting OpenLDAP: "
18 start-stop-daemon --start --quiet --exec $slapd
19 echo "."
20 ;;
21 stop)
22 echo -n "Stopping OpenLDAP: "
23 start-stop-daemon --stop --quiet --pidfile /var/run/slapd.pid
24 echo "."
25 ;;
26 status)
27 status $slapd;
28 exit $?
29 ;;
30 *)
31 echo "Usage: /etc/init.d/openldap {start|stop|status}"
32 exit 1
33esac
34
35exit 0
diff --git a/meta-oe/recipes-support/openldap/openldap/install-strip.patch b/meta-oe/recipes-support/openldap/openldap/install-strip.patch
new file mode 100644
index 000000000..2992b7030
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/install-strip.patch
@@ -0,0 +1,14 @@
1# This patch ensures that the install operations which strip
2# programs and libraries (LTINSTALL) work in a cross build
3# environment.
4--- openldap-2.2.24/.pc/install-strip.patch/build/top.mk 2005-01-20 09:00:55.000000000 -0800
5+++ openldap-2.2.24/build/top.mk 2005-04-16 13:48:20.536710376 -0700
6@@ -116,7 +116,7 @@
7 LTLINK_MOD = $(LIBTOOL) $(LTONLY_MOD) --mode=link \
8 $(CC) $(LT_CFLAGS) $(LDFLAGS) $(LTFLAGS_MOD)
9
10-LTINSTALL = $(LIBTOOL) --mode=install $(INSTALL)
11+LTINSTALL = STRIPPROG="" $(LIBTOOL) --mode=install $(top_srcdir)/contrib/ldapc++/install-sh -c
12 LTFINISH = $(LIBTOOL) --mode=finish
13
14 # Misc UNIX commands used in build environment
diff --git a/meta-oe/recipes-support/openldap/openldap/kill-icu.patch b/meta-oe/recipes-support/openldap/openldap/kill-icu.patch
new file mode 100644
index 000000000..dcf541137
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/kill-icu.patch
@@ -0,0 +1,30 @@
1From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
2
3slapd depends on ICU if it was built first.
4
5Upstream-status: inappropiate [embedded specific]
6---
7 configure.in | 8 --------
8 1 file changed, 8 deletions(-)
9
10--- openldap-2.4.23.orig/configure.in
11+++ openldap-2.4.23/configure.in
12@@ -2045,18 +2045,10 @@ if test $ol_enable_ndb != no ; then
13 SLAPD_LIBS="$SLAPD_LIBS \$(SLAPD_NDB_LIBS)"
14 fi
15 fi
16
17 dnl ----------------------------------------------------------------
18-dnl International Components for Unicode
19-OL_ICU
20-if test "$ol_icu" = no ; then
21- AC_MSG_WARN([ICU not available])
22-else
23- ICU_LIBS="$ol_icu"
24-fi
25-dnl ----------------------------------------------------------------
26 dnl
27 dnl Check for Cyrus SASL
28 dnl
29 WITH_SASL=no
30 ol_link_sasl=no
diff --git a/meta-oe/recipes-support/openldap/openldap/openldap-2.4.28-gnutls-gcrypt.patch b/meta-oe/recipes-support/openldap/openldap/openldap-2.4.28-gnutls-gcrypt.patch
new file mode 100644
index 000000000..c7b1552c1
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/openldap-2.4.28-gnutls-gcrypt.patch
@@ -0,0 +1,17 @@
1From http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-nds/openldap/files/
2
3Upstream-status: Unknown
4
5--
6
7--- openldap-2.4.28/configure.in.orig 2012-02-11 22:40:36.004360795 +0000
8+++ openldap-2.4.28/configure.in 2012-02-11 22:40:13.410986851 +0000
9@@ -1214,7 +1214,7 @@
10 ol_with_tls=gnutls
11 ol_link_tls=yes
12
13- TLS_LIBS="-lgnutls"
14+ TLS_LIBS="-lgnutls -lgcrypt"
15
16 AC_DEFINE(HAVE_GNUTLS, 1,
17 [define if you have GNUtls])
diff --git a/meta-oe/recipes-support/openldap/openldap/openldap-m4-pthread.patch b/meta-oe/recipes-support/openldap/openldap/openldap-m4-pthread.patch
new file mode 100644
index 000000000..b669b7254
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/openldap-m4-pthread.patch
@@ -0,0 +1,20 @@
1--- openldap-2.3.11/build/openldap.m4.orig 2005-11-11 00:11:18.604322590 -0800
2+++ openldap-2.3.11/build/openldap.m4 2005-11-11 00:26:21.621145856 -0800
3@@ -788,7 +788,7 @@ AC_DEFUN([OL_PTHREAD_TEST_FUNCTION],[[
4 ]])
5
6 AC_DEFUN([OL_PTHREAD_TEST_PROGRAM],
7-AC_LANG_SOURCE([OL_PTHREAD_TEST_INCLUDES
8+[AC_LANG_SOURCE([[OL_PTHREAD_TEST_INCLUDES
9
10 int main(argc, argv)
11 int argc;
12@@ -796,7 +796,7 @@ int main(argc, argv)
13 {
14 OL_PTHREAD_TEST_FUNCTION
15 }
16-]))
17+]])])
18 dnl --------------------------------------------------------------------
19 AC_DEFUN([OL_PTHREAD_TRY], [# Pthread try link: $1 ($2)
20 if test "$ol_link_threads" = no ; then
diff --git a/meta-oe/recipes-support/openldap/openldap/slapd.service b/meta-oe/recipes-support/openldap/openldap/slapd.service
new file mode 100644
index 000000000..f5f83fdc3
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/slapd.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Standalone LDAP Daemon
3After=syslog.target network.target
4
5[Service]
6Type=forking
7ExecStart=@SBINDIR@/slapd
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-oe/recipes-support/openldap/openldap/thread_stub.patch b/meta-oe/recipes-support/openldap/openldap/thread_stub.patch
new file mode 100644
index 000000000..540ba4a63
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/thread_stub.patch
@@ -0,0 +1,20 @@
1openldap: set pointer
2
3When the function ldap_pvt_thread_pool_getkey() succeeds, it
4must set the value of *data since the caller may try to use it.
5
6Upstream-Status: pending
7
8Signed-off-by: Joe Slater <jslater@windriver.com>
9
10
11--- a/libraries/libldap_r/thr_stub.c
12+++ b/libraries/libldap_r/thr_stub.c
13@@ -217,6 +217,7 @@ ldap_pvt_thread_pool_unidle ( ldap_pvt_t
14 int ldap_pvt_thread_pool_getkey (
15 void *ctx, void *key, void **data, ldap_pvt_thread_pool_keyfree_t **kfree )
16 {
17+ if (data) *data = NULL; /* avoid problems with uninitialized *data */
18 return(0);
19 }
20
diff --git a/meta-oe/recipes-support/openldap/openldap/use-urandom.patch b/meta-oe/recipes-support/openldap/openldap/use-urandom.patch
new file mode 100644
index 000000000..e7b988faf
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/use-urandom.patch
@@ -0,0 +1,38 @@
1openldap: assume /dev/urandom exists
2
3When we are cross-compiling, we want to assume
4that /dev/urandom exists. We could change the source
5code to look for it, but this is the easy way out.
6
7Upstream-Status: pending
8
9Signed-off-by: Joe Slater <jslater@windriver.com>
10
11
12--- a/configure.in
13+++ b/configure.in
14@@ -2142,8 +2142,8 @@ fi
15
16 dnl ----------------------------------------------------------------
17 dnl Check for entropy sources
18+dev=no
19 if test $cross_compiling != yes && test "$ac_cv_mingw32" != yes ; then
20- dev=no
21 if test -r /dev/urandom ; then
22 dev="/dev/urandom";
23 elif test -r /idev/urandom ; then
24@@ -2156,9 +2156,11 @@ if test $cross_compiling != yes && test
25 dev="/idev/random";
26 fi
27
28- if test $dev != no ; then
29- AC_DEFINE_UNQUOTED(URANDOM_DEVICE,"$dev",[set to urandom device])
30- fi
31+elif test $cross_compiling == yes ; then
32+ dev="/dev/urandom";
33+fi
34+if test $dev != no ; then
35+ AC_DEFINE_UNQUOTED(URANDOM_DEVICE,"$dev",[set to urandom device])
36 fi
37
38 dnl ----------------------------------------------------------------