summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch')
-rw-r--r--meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch b/meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch
deleted file mode 100644
index 6e73f8b38..000000000
--- a/meta-oe/recipes-support/openldap/openldap/0001-configure-Pass-pthread_t-to-pthread_detach.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 7577b120acda087bf3f5f613c2c72663b3864ad8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 4 Sep 2022 09:43:06 -0700
4Subject: [PATCH] configure: Pass pthread_t to pthread_detach
5
6This helps compilers when using C2X standard
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 configure.ac | 5 +----
12 1 file changed, 1 insertion(+), 4 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 0978eeb..58d15f8 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -1467,10 +1467,7 @@ pthread_rwlock_t rwlock;
19 dnl save the flags
20 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
21 #include <pthread.h>
22-#ifndef NULL
23-#define NULL (void*)0
24-#endif
25-]], [[pthread_detach(NULL);]])],[ol_cv_func_pthread_detach=yes],[ol_cv_func_pthread_detach=no])
26+]], [[pthread_detach((pthread_t)-1);]])],[ol_cv_func_pthread_detach=yes],[ol_cv_func_pthread_detach=no])
27 ])
28
29 if test $ol_cv_func_pthread_detach = no ; then
30--
312.37.3
32