summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index 81e8e9624..c32d2c5b3 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -24,6 +24,7 @@ LICENSE_modules/solaris = "CDDL-1.0"
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \ 24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
25 file://tools.conf \ 25 file://tools.conf \
26 file://vmtoolsd.service \ 26 file://vmtoolsd.service \
27 file://vmtoolsd.init \
27 file://0001-configure.ac-don-t-use-dnet-config.patch \ 28 file://0001-configure.ac-don-t-use-dnet-config.patch \
28 file://0002-add-include-sys-sysmacros.h.patch \ 29 file://0002-add-include-sys-sysmacros.h.patch \
29 file://0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch \ 30 file://0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch \
@@ -50,7 +51,7 @@ DEPENDS_append_libc-musl = " libtirpc"
50# open-vm-tools is supported only on x86. 51# open-vm-tools is supported only on x86.
51COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' 52COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
52 53
53inherit autotools pkgconfig systemd 54inherit autotools pkgconfig systemd update-rc.d
54 55
55SYSTEMD_SERVICE_${PN} = "vmtoolsd.service" 56SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
56 57
@@ -85,8 +86,14 @@ RDEPENDS_${PN} = "util-linux libdnet fuse"
85 86
86do_install_append() { 87do_install_append() {
87 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs 88 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
88 install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools 89 install -d ${D}${sysconfdir}/vmware-tools
89 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system 90 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
91 install -d ${D}${systemd_unitdir}/system
92 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
93 else
94 install -d ${D}${sysconfdir}/init.d
95 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
96 fi
90 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf 97 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
91} 98}
92 99
@@ -95,6 +102,10 @@ do_configure_prepend() {
95 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so 102 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
96} 103}
97 104
105INITSCRIPT_PACKAGES = "${PN}"
106INITSCRIPT_NAME_${PN} = "vmtoolsd"
107INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
108
98python() { 109python() {
99 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \ 110 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
100 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split(): 111 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():