summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/numactl/numactl_2.0.10.bb')
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.10.bb21
1 files changed, 16 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.10.bb b/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
index 3a10ebbee..8f27b156b 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
@@ -15,6 +15,7 @@ SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
15 file://Fix-the-test-output-format.patch \ 15 file://Fix-the-test-output-format.patch \
16 file://Makefile \ 16 file://Makefile \
17 file://run-ptest \ 17 file://run-ptest \
18 file://0001-define-run-test-target.patch \
18 " 19 "
19SRC_URI[md5sum] = "682c38305b2596967881f3d77bc3fc9c" 20SRC_URI[md5sum] = "682c38305b2596967881f3d77bc3fc9c"
20SRC_URI[sha256sum] = "dbdac8fe74f13b2e2864bba352f1597ab1d3345c8c485d7805f58d66f414db61" 21SRC_URI[sha256sum] = "dbdac8fe74f13b2e2864bba352f1597ab1d3345c8c485d7805f58d66f414db61"
@@ -28,19 +29,29 @@ do_install() {
28 rm -r ${D}${mandir}/man2 29 rm -r ${D}${mandir}/man2
29} 30}
30 31
32do_compile_ptest() {
33 oe_runmake test
34}
35
31do_install_ptest() { 36do_install_ptest() {
32 #install tests binaries 37 #install tests binaries
33 local test_binaries="checkaffinity checktopology distance \ 38 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
34 ftok mbind_mig_pages migrate_pages move_pages mynode \ 39 mynode nodemap node-parse pagesize prefered randmap realloc_test \
35 nodemap pagesize prefered printcpu randmap realloc_test \ 40 tbitmap tshared"
36 regress regress2 runltp shmtest tbitmap tshared bind_range"
37 41
38 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test 42 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
39 for i in $test_binaries; do 43 for i in $test_binaries; do
44 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
45 done
46
47 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
48 shmtest runltp bind_range"
49 for i in $test_scripts; do
40 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test 50 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
41 done 51 done
52
42 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/ 53 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
43 install -m 0755 ${B}/numactl ${D}${PTEST_PATH}/ 54 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
44} 55}
45 56
46RDEPENDS_${PN}-ptest = "bash" 57RDEPENDS_${PN}-ptest = "bash"