summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch')
-rw-r--r--meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch b/meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch
new file mode 100644
index 000000000..33fd17acd
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mysql5/Makefile.am.patch
@@ -0,0 +1,19 @@
1Index: mysql-5.1.40/sql/Makefile.am
2===================================================================
3--- mysql-5.1.40.orig/sql/Makefile.am
4+++ mysql-5.1.40/sql/Makefile.am
5@@ -174,10 +174,10 @@ link_sources:
6 # This generates lex_hash.h
7 # NOTE Built sources should depend on their sources not the tool
8 # this avoid the rebuild of the built files in a source dist
9-lex_hash.h: gen_lex_hash.cc lex.h
10- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
11- ./gen_lex_hash$(EXEEXT) > $@-t
12- $(MV) $@-t $@
13+GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
14+
15+lex_hash.h: gen_lex_hash$(EXEEXT)
16+ $(GEN_LEX_HASH) > $@
17
18 # For testing of udf_example.so
19 udf_example_la_SOURCES= udf_example.c