summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch b/meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch
new file mode 100644
index 000000000..8d9f558d0
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix-cmake-module-path.patch
@@ -0,0 +1,29 @@
1Avoid CMAKE_MODULE_PATH being overwritten
2
3OE-Core's setting of CMAKE_MODULE_PATH stomps on MariaDB's value unless
4we set it after setting the project name.
5
6Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
7
8Upstream-Status: Inappropriate [working around OE-Core bug]
9
10--- mariadb/CMakeLists.txt 2014-07-17 11:01:07.676353047 +0100
11+++ mariadb/CMakeLists.txt 2014-07-17 11:01:31.299353107 +0100
12@@ -28,8 +28,6 @@
13
14 MESSAGE(STATUS "Running cmake version ${CMAKE_VERSION}")
15
16-SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
17-
18 # Distinguish between community and non-community builds, with the
19 # default being a community build. This does not impact the feature
20 # set that will be compiled in; it's merely provided as a hint to
21@@ -77,6 +75,8 @@
22 ENDIF()
23 PROJECT(${MYSQL_PROJECT_NAME})
24
25+SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
26+
27 IF(BUILD_CONFIG)
28 INCLUDE(
29 ${CMAKE_SOURCE_DIR}/cmake/build_configurations/${BUILD_CONFIG}.cmake)