summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch')
-rw-r--r--meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch b/meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch
new file mode 100644
index 000000000..3b5b3fd06
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/files/configure-ps-cache-check.patch
@@ -0,0 +1,27 @@
1Index: mysql-4.1.22/configure.in
2===================================================================
3--- mysql-4.1.22.orig/configure.in 2009-01-28 16:33:28.000000000 +0000
4+++ mysql-4.1.22/configure.in 2009-01-28 16:43:26.000000000 +0000
5@@ -471,8 +471,8 @@
6
7 # Lock for PS
8 AC_PATH_PROG(PS, ps, ps)
9-AC_MSG_CHECKING("how to check if pid exists")
10-PS=$ac_cv_path_PS
11+AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
12+[
13 # Linux style
14 if $PS p $$ 2> /dev/null | grep $0 > /dev/null
15 then
16@@ -511,8 +511,9 @@
17 AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
18 esac
19 fi
20-AC_SUBST(FIND_PROC)
21-AC_MSG_RESULT("$FIND_PROC")
22+ac_cv_FIND_PROC="$FIND_PROC"
23+])
24+AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
25
26 # Check if a pid is valid
27 AC_PATH_PROG(KILL, kill, kill)