summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch')
-rw-r--r--meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch b/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
new file mode 100644
index 000000000..ff71f3967
--- /dev/null
+++ b/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
@@ -0,0 +1,36 @@
1multipath-tools: modify Makefile.inc for cross-compilation
2
3Do not look for systemd info on the host, and allow us to pass in CFLAGS
4using the OPTFLAGS variable.
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: Joe Slater <joe.slater@windriver.com>
9
10
11--- a/Makefile.inc
12+++ b/Makefile.inc
13@@ -21,12 +21,6 @@ ifndef LIB
14 endif
15 endif
16
17-ifndef SYSTEMD
18- ifeq ($(shell systemctl --version > /dev/null 2>&1 && echo 1), 1)
19- SYSTEMD = $(shell systemctl --version 2> /dev/null | sed -n 's/systemd \([0-9]*\)/\1/p')
20- endif
21-endif
22-
23 prefix =
24 exec_prefix = $(prefix)
25 bindir = $(exec_prefix)/sbin
26@@ -49,7 +43,10 @@ ifndef RPM_OPT_FLAGS
27 RPM_OPT_FLAGS = -O2 -g -pipe -Wformat-security -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
28 endif
29
30+ifndef OPTFLAGS
31 OPTFLAGS = $(RPM_OPT_FLAGS) -Wunused -Wstrict-prototypes
32+endif
33+
34 CFLAGS = $(OPTFLAGS) -fPIC -DLIB_STRING=\"${LIB}\"
35 SHARED_FLAGS = -shared
36