summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_1.09.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_1.09.bb32
1 files changed, 21 insertions, 11 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.09.bb b/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
index 34ff643a5..542b2ba19 100644
--- a/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
+++ b/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
@@ -4,23 +4,33 @@ and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks
4and should run on all Linux systems that need error handling." 4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/" 5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base" 6SECTION = "System Environment/Base"
7DEPENDS += "bash" 7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git" 8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git \
9 file://mcelog-debash.patch \
10 file://run-ptest \
11"
12
9SRCREV = "0fc9f702232cb2d9969916f899c67c3e64deedda" 13SRCREV = "0fc9f702232cb2d9969916f899c67c3e64deedda"
14
10LICENSE = "GPLv2" 15LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://README;md5=3eb76ca64fa07ad53ebb0ebb5b4c8ede" 16LIC_FILES_CHKSUM = "file://README;md5=3eb76ca64fa07ad53ebb0ebb5b4c8ede"
12 17
13S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
14 19
15do_install() { 20inherit autotools-brokensep ptest
16 install -d ${D}/${sbindir}
17 install -m 0755 ${S}/mcelog ${D}/${sbindir}
18 install -d ${D}/${mandir}/man8
19 install -m 0644 ${S}/mcelog.8 ${D}/${mandir}/man8/
20 install -d ${D}/etc/cron.hourly
21 install -m 0755 ${S}/mcelog.cron ${D}/etc/cron.hourly/
22}
23 21
24COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' 22COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
25 23
26RDEPENDS_${PN} = "bash" 24do_install_append() {
25 install -d ${D}${sysconfdir}/cron.hourly
26 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
27 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}
32 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
33 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
34}
35
36RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"