diff options
Diffstat (limited to 'meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb')
-rw-r--r-- | meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | 75 |
1 files changed, 0 insertions, 75 deletions
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb deleted file mode 100644 index 844e5acf9..000000000 --- a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb +++ /dev/null | |||
@@ -1,75 +0,0 @@ | |||
1 | SUMMARY = "lio-utils" | ||
2 | DESCRIPTION = "a simple low-level configuration tool set for the Target+iSCSI (LIO)" | ||
3 | HOMEPAGE = "http://linux-iscsi.org/index.php/Lio-utils" | ||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df" | ||
6 | |||
7 | PV = "4.1+git" | ||
8 | |||
9 | SRC_URI = "git://github.com/Datera/lio-utils.git;branch=master;protocol=https \ | ||
10 | file://0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch \ | ||
11 | " | ||
12 | SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "distutils", "", d)} | ||
16 | |||
17 | EXTRA_OEMAKE += "DESTDIR=${D}" | ||
18 | |||
19 | do_compile() { | ||
20 | cd ${S}/tcm-py | ||
21 | distutils_do_compile | ||
22 | |||
23 | cd ${S}/lio-py | ||
24 | distutils_do_compile | ||
25 | |||
26 | if test -d ${S}/tools; then | ||
27 | oe_runmake -C ${S}/tools | ||
28 | fi | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | cd ${S}/tcm-py | ||
33 | distutils_do_install | ||
34 | |||
35 | cd ${S}/lio-py | ||
36 | distutils_do_install | ||
37 | |||
38 | SITE_PACKAGES=${D}/${PYTHON_SITEPACKAGES_DIR} | ||
39 | install -d ${D}/${sbindir} | ||
40 | for var in tcm_node tcm_dump tcm_loop tcm_fabric lio_dump lio_node; do | ||
41 | if [ ! -h ${D}/${sbindir}/${var} ];then | ||
42 | chmod a+x ${SITE_PACKAGES}/${var}.py | ||
43 | ln -s ${PYTHON_SITEPACKAGES_DIR}/${var}.py ${D}/${sbindir}/${var} | ||
44 | fi | ||
45 | done | ||
46 | |||
47 | if test -d ${S}/tools; then | ||
48 | oe_runmake -C ${S}/tools install | ||
49 | fi | ||
50 | |||
51 | install -d ${D}/etc/target/ | ||
52 | install -d ${D}/etc/init.d/ | ||
53 | install -m 755 ${S}/scripts/rc.target ${D}/etc/init.d/ | ||
54 | install -m 755 ${S}/conf/tcm_start.default ${D}/etc/target/tcm_start.sh | ||
55 | install -m 755 ${S}/conf/lio_start.default ${D}/etc/target/lio_start.sh | ||
56 | } | ||
57 | |||
58 | SKIP_RECIPE[lio-utils] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}" | ||
59 | |||
60 | RDEPENDS:${PN} += "python-stringold python-subprocess python-shell \ | ||
61 | python-datetime python-textutils python-crypt python-netclient python-email \ | ||
62 | bash" | ||
63 | |||
64 | FILES:${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*" | ||
65 | |||
66 | # http://errors.yoctoproject.org/Errors/Details/184712/ | ||
67 | # python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory | ||
68 | CLEANBROKEN = "1" | ||
69 | |||
70 | python() { | ||
71 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
72 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') | ||
73 | } | ||
74 | |||
75 | |||