summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb')
-rw-r--r--meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb b/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb
new file mode 100644
index 000000000..b02bc1281
--- /dev/null
+++ b/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb
@@ -0,0 +1,32 @@
1SUMMARY = "API for managing information about operating systems, hypervisors and the (virtual) hardware devices."
2HOMEPAGE = "https://libosinfo.org"
3
4LICENSE = "LGPL-2.1-only & GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2b0e9926530c269f5ae95560370195af"
6LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = " \
9 git://gitlab.com/libosinfo/libosinfo.git;branch=main;protocol=https \
10 file://0001-meson.build-allow-crosscompiling-gir.patch \
11"
12
13SRCREV = "f503ff7a9e13963bcf396776bce0b209a819ba9b"
14
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig gtk-doc gobject-introspection vala
18
19DEPENDS = "glib-2.0 libsoup libxslt"
20
21GIR_MESON_OPTION = "enable-introspection"
22GIR_MESON_ENABLE_FLAG = 'enabled'
23GIR_MESON_DISABLE_FLAG = 'disabled'
24GTKDOC_MESON_OPTION = "enable-gtk-doc"
25
26EXTRA_OEMESON = " \
27 -Dwith-pci-ids-path=${datadir}/pci.ids \
28 -Dwith-usb-ids-path=${datadir}/usb.ids \
29 -Denable-vala=enabled \
30"
31
32RDEPENDS:${PN} = "pciutils-ids usbids"