summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libol
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libol')
-rw-r--r--meta-oe/recipes-support/libol/libol/configure.patch14
-rw-r--r--meta-oe/recipes-support/libol/libol_0.3.18.bb19
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libol/libol/configure.patch b/meta-oe/recipes-support/libol/libol/configure.patch
new file mode 100644
index 000000000..87695fb06
--- /dev/null
+++ b/meta-oe/recipes-support/libol/libol/configure.patch
@@ -0,0 +1,14 @@
1Index: libol-0.3.18/configure.in
2===================================================================
3--- libol-0.3.18.orig/configure.in 2006-03-27 14:44:52.000000000 +0000
4+++ libol-0.3.18/configure.in 2014-07-18 07:05:56.029481372 +0000
5@@ -1,7 +1,7 @@
6 dnl Process this file with autoconf to produce a configure script.
7-AC_INIT(src/abstract_io.c)
8+AC_INIT(libol, "0.3.18")
9
10-AM_INIT_AUTOMAKE(libol, "0.3.18", 1)
11+AM_INIT_AUTOMAKE([foreign])
12 if test -n "$SNAPSHOT_VERSION"; then
13 VERSION=$VERSION+$SNAPSHOT_VERSION
14 fi
diff --git a/meta-oe/recipes-support/libol/libol_0.3.18.bb b/meta-oe/recipes-support/libol/libol_0.3.18.bb
new file mode 100644
index 000000000..c31f48313
--- /dev/null
+++ b/meta-oe/recipes-support/libol/libol_0.3.18.bb
@@ -0,0 +1,19 @@
1SUMMARY = "A tiny C support library"
2SECTION = "libs"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
5
6SRC_URI = "http://www.balabit.com/downloads/files/libol/0.3/${BP}.tar.gz \
7 file://configure.patch"
8SRC_URI[md5sum] = "cbadf4b7ea276dfa85acc38a1cc5ff17"
9SRC_URI[sha256sum] = "9de3bf13297ff882e02a1e6e5f6bf760a544aff92a9d8a1cf4328a32005cefe7"
10
11inherit autotools binconfig
12
13do_compile_prepend() {
14 install ${S}/utils/make_class.in ${B}/utils
15}
16
17do_install_append() {
18 rm -fr ${D}${bindir}
19}