diff options
Diffstat (limited to 'meta-oe/recipes-support/libnih')
-rw-r--r-- | meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/libnih/libnih_1.0.3.bb | 5 |
2 files changed, 31 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch b/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch new file mode 100644 index 000000000..a43b4b176 --- /dev/null +++ b/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From f1b9992caf9910f9f7afae401045e42572cc84ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 1 Apr 2017 08:50:35 -0700 | ||
4 | Subject: [PATCH] signal.c: SIGCLD and SIGCHILD are same on sytem V systems | ||
5 | |||
6 | Musl drops the SIGCLD legacy | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | nih/signal.c | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/nih/signal.c b/nih/signal.c | ||
14 | index a241df9..691c8e6 100644 | ||
15 | --- a/nih/signal.c | ||
16 | +++ b/nih/signal.c | ||
17 | @@ -87,7 +87,7 @@ static const SignalName signal_names[] = { | ||
18 | { SIGSTKFLT, "STKFLT" }, | ||
19 | #endif | ||
20 | { SIGCHLD, "CHLD" }, | ||
21 | - { SIGCLD, "CLD" }, | ||
22 | + { SIGCHLD, "CLD" }, | ||
23 | { SIGCONT, "CONT" }, | ||
24 | { SIGSTOP, "STOP" }, | ||
25 | { SIGTSTP, "TSTP" }, | ||
26 | -- | ||
27 | 2.12.1 | ||
28 | |||
diff --git a/meta-oe/recipes-support/libnih/libnih_1.0.3.bb b/meta-oe/recipes-support/libnih/libnih_1.0.3.bb index 40aa8964e..02fe805fc 100644 --- a/meta-oe/recipes-support/libnih/libnih_1.0.3.bb +++ b/meta-oe/recipes-support/libnih/libnih_1.0.3.bb | |||
@@ -23,8 +23,9 @@ DEPENDS = "dbus libnih-native" | |||
23 | DEPENDS_class-native = "dbus-native" | 23 | DEPENDS_class-native = "dbus-native" |
24 | 24 | ||
25 | SRC_URI = "https://launchpad.net/${BPN}/1.0/${PV}/+download/${BP}.tar.gz \ | 25 | SRC_URI = "https://launchpad.net/${BPN}/1.0/${PV}/+download/${BP}.tar.gz \ |
26 | file://libnih_1.0.3-4ubuntu16.patch \ | 26 | file://libnih_1.0.3-4ubuntu16.patch \ |
27 | " | 27 | file://0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch \ |
28 | " | ||
28 | 29 | ||
29 | SRC_URI[md5sum] = "db7990ce55e01daffe19006524a1ccb0" | 30 | SRC_URI[md5sum] = "db7990ce55e01daffe19006524a1ccb0" |
30 | SRC_URI[sha256sum] = "897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405" | 31 | SRC_URI[sha256sum] = "897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405" |