summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libmicrohttpd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libmicrohttpd')
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb
new file mode 100644
index 000000000..523b8dd4e
--- /dev/null
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "libgcrypt gnutls"
7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "013b10f9de1cda5448b29c81305354a3"
10SRC_URI[sha256sum] = "d9587e8497548f820650cd607daf3615ea3272435779378983032c570f1cd559"
11
12inherit autotools lib_package
13
14EXTRA_OECONF += "-disable-static --enable-gnutls"
15
16PACKAGECONFIG ?= "curl"
17PACKAGECONFIG_append_class-target = "\
18 ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
19"
20PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
21PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
22
23do_compile_append() {
24 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25}
26